This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 139369 - Holding CTRL for > 3 seconds in KDE causes mouse to freeze
Holding CTRL for > 3 seconds in KDE causes mouse to freeze
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 11:53 EST by Robert Petty
Modified: 2015-01-04 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 17:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Petty 2004-11-15 11:53:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have noted several occurances of the mouse freezing while I perform
activities within KDE.  I have mainly noticed it with accessing the VT
Options in the Xterm windows (CTRL+Middle Mouse Button).  However, I
have identified that this occurs no matter which window I am in if I
press and hold the CTRL key for more than 3 seconds.  

I am able to restore mouse movement by running hwbrowser.

Version-Release number of selected component (if applicable):
kdebase-3.3.1-4.1

How reproducible:
Always

Steps to Reproduce:
1.load KDE
2.Move mouse to verify it works
3.Press and hold the CTRL key for 4+ seconds
4.Verify the mouse doesn't move anymore
5.Run hwbrowser to restore use of mouse
    

Actual Results:  As reported

Additional info:

HW is:
Dell Precision 670 tower, 2x3G Xeon, 1G RAM, SATA Disks.
MS "Wheel Mouse Optical USB and PS/2 Compatible" connected via USB

output of lspci and lsusb:
[root@dris84lx ~]# lspci
00:00.0 Host bridge: Intel Corp. E7525 Memory Controller Hub (rev 09)
00:00.1 Class ff00: Intel Corp. E7525/E7520 Error Reporting Registers
(rev 09)
00:02.0 PCI bridge: Intel Corp. E7525/E7520/E7320 PCI Express Port A
(rev 09)
00:03.0 PCI bridge: Intel Corp. E7525/E7520/E7320 PCI Express Port A1
(rev 09)
00:04.0 PCI bridge: Intel Corp. E7525/E7520 PCI Express Port B (rev 09)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) IDE
Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corp. 82801ER (ICH5R) SATA
Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 PCI bridge: Intel Corp. 6700PXH PCI Express-to-PCI Bridge A
01:00.2 PCI bridge: Intel Corp. 6700PXH PCI Express-to-PCI Bridge B
03:0e.0 Ethernet controller: Intel Corp. 82545GM Gigabit Ethernet
Controller (rev 04)
05:00.0 VGA compatible controller: nVidia Corporation NV38GL [Quadro
FX 1300] (rev a2)
06:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A
IEEE-1394a-2000 Controller (PHY/Link)
[root@dris84lx ~]# lsusb
Bus 005 Device 003: ID 045e:001c Microsoft Corp. 
Bus 005 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 005 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 010: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 009: ID 04b8:0116 Seiko Epson Corp. 
Bus 001 Device 008: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 007: ID 0424:223a Standard Microsystems Corp. 
Bus 001 Device 001: ID 0000:0000  
[root@dris84lx ~]#
Comment 1 Ngo Than 2004-11-15 12:03:56 EST
sorry, i tried with your instructions and it works fine for me.

if you could give me a exactly instructions how to reproduce this
problem, please reopen it again. Thanks
Comment 2 Robert Petty 2004-11-15 16:19:44 EST
Please retry and move your mouse around simultaneously.  It is easily
reproduced on this brand FC3 system.
Comment 3 Ngo Than 2004-11-16 04:54:02 EST
it's strange, i have tried on many machines here again. it works for me!
Does this problem appear under GNOME or XFCE instead KDE ?
Comment 4 Robert Petty 2004-11-16 10:51:37 EST
Actually, I hadn't tried before you asked...

It happens:
In GDM,
In Gnome,
In XFCE,
In KDE,
At the mingetty console (tty1)...

This is clearly more deeply rooted than just the KDE window manager. 
But given that this happens with gpm as well as under X, I can't blame
the NVidia driver.  Seems to be more related to the hardware.

Thanks for looking into it. I will keep digging and see what I can find.

-Rob
Comment 5 Ngo Than 2004-11-16 11:00:32 EST
ok, it's definitive not a bug in KDE. it seems a bug in kernel (USB
driver).
Comment 6 Dave Jones 2004-11-17 17:26:33 EST
if you're using the nvidia binary driver, there's nothing we can do.
complain to them.


*** This bug has been marked as a duplicate of 73733 ***
Comment 7 Joerg-Volker Peetz 2004-12-03 04:29:59 EST
On my Dell Precision 360 with USB mouse this phenomena also happens if
pressing the CTRL key and moving the mouse around. Additionally it
also happens if pressing the SHIFT key and moving the mouse around.
This is really annoying because I have to work with CAE programs where
on has to press one of the mentioned keys in order to move the model.
Has anybody tried a BIOS update from Dell to cure this bug?
Comment 8 Robert Petty 2004-12-03 15:40:28 EST
*** JUST FYI ***

For anyone who encounters this issue...

I just observed the fact that running xorg X as a non-root user I do
not experience the above behaviour.  The issue appears to only apply
to sessions where X is running as root. (Why are you running X as
root? Are you NUTS? Wise up! ... like i eventually did ... though I
did it so my screen saver /BSOD/ would run, which it doesn't and I
have to fight yet another issue argh...  Still, it's better without
MS!  ;)

Good Luck.

Note You need to log in before you can comment on or make changes to this bug.