Bug 1393726 - Enumerate all available request type options in ipa cert-request help
Summary: Enumerate all available request type options in ipa cert-request help
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Mohammad Rizwan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-10 08:45 UTC by Abhijeet Kasurde
Modified: 2017-08-01 09:42 UTC (History)
4 users (show)

Fixed In Version: ipa-4.5.0-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:42:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Abhijeet Kasurde 2016-11-10 08:45:10 UTC
Description of problem:
ipa cert-request command help should enumerate all available request type

# ipa help cert-request
Usage: ipa [global-options] cert-request CSR-FILE [options]

Submit a certificate signing request.
Options:
  -h, --help            show this help message and exit
  --request-type=STR    <request_type>
  --profile-id=STR      Certificate Profile to use
  --ca=STR              Name of issuing CA
  --principal=PRINCIPAL
                        Principal for this certificate (e.g.
                        HTTP/test.example.com)
  --add                 automatically add the principal if it doesn't exist
                        (service principals only)
  --all                 Retrieve and print all attributes from the server.
                        Affects command output.
  --raw                 Print entries as stored on the server. Only affects
                        output format.

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-14.el7_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ipa cert-request --help

Actual results:
Help shows <request_type> for request type in ipa cert-request

Expected results:
Help should show pkcs10/12/7 or all supported request type in ipa cert-request help

Comment 2 Petr Vobornik 2016-11-16 19:50:14 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6494

Comment 5 Mohammad Rizwan 2017-05-30 06:06:31 UTC
version:
ipa-server-4.5.0-13.el7.x86_64

[root@hp-dl380pgen8-02-vm-10 ~]# ipa cert-request --help
Usage: ipa [global-options] cert-request CSR-FILE [options]

Submit a certificate signing request.
Options:
  -h, --help            show this help message and exit
  --profile-id=STR      Certificate Profile to use
  --ca=STR              Name of issuing CA
  --principal=PRINCIPAL
                        Principal for this certificate (e.g.
                        HTTP/test.example.com)
  --add                 automatically add the principal if it doesn't exist
                        (service principals only)
  --chain               Include certificate chain in output
  --all                 Retrieve and print all attributes from the server.
                        Affects command output.
  --raw                 Print entries as stored on the server. Only affects
                        output format.
  --certificate-out=FILE
                        Write certificate (chain if --chain used) to file

[root@hp-dl380pgen8-02-vm-10 ~]# ipa cert-request --principal=admin --ca=ipa --raw  --request-type=pkcs10
Usage: ipa [global-options] cert-request CSR-FILE [options]

ipa: error: no such option: --request-type
[root@hp-dl380pgen8-02-vm-10 ~]#

Comment 7 errata-xmlrpc 2017-08-01 09:42:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.