Bug 139393 - Gnome Pilot applet gets stuck synchronising calendar information from a PDA
Gnome Pilot applet gets stuck synchronising calendar information from a PDA
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-pilot-conduits (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC3Update 161133
  Show dependency treegraph
 
Reported: 2004-11-15 14:38 EST by Michael Waite
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-connector-2.0.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 14:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix broken pilot synchronization (506 bytes, patch)
2005-03-22 10:05 EST, Aaron Gaudio
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Ximian Software (Novell) 73975 None None None Never

  None (edit)
Description Michael Waite 2004-11-15 14:38:16 EST
Description of problem:
Gnome Pilot applet gets stuck synchronising calendar information from
a PDA.

Version-Release number of selected component (if applicable):
gnome-pilot-conduits-2.0.12-3

How reproducible:
100%

Steps to Reproduce:
1. set up gnome-pilot ECalendar to sync or to get from PDA
2. try syncing

  
Actual results:
Sync of data

Expected results:
Seems to get stuck with top progress bar at about 10%, with lower
progress bar going back on forth like crazy. 

Additional info:
Attaching to the gpilot process yields this backtrace:
#0  0x00b347a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00d93ac6 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
#2  0xf56ddc25 in e_cal_remove_object_with_mod ()
   from /usr/lib/libecal.so.6
#3  0xf56ddd26 in e_cal_remove_object () from /usr/lib/libecal.so.6
#4  0xf57685c1 in ?? ()
   from /usr/lib/evolution/2.0/conduits/libecalendar_conduit.so
#5  0x09e0f2f8 in ?? ()
#6  0x09daacf0 in ?? ()
#7  0x00000000 in ?? ()
Comment 1 Michael Waite 2004-11-15 14:40:01 EST
Works for getting data from computer to PDA; problem appears to be
gettingdata from PDA to computer, and is specifically
calendar-related; e.g. contacts work as expected
Comment 2 Dave Malcolm 2004-11-16 17:42:29 EST
*** Bug 139617 has been marked as a duplicate of this bug. ***
Comment 3 Aaron Gaudio 2005-03-16 18:24:01 EST
I'm using evolution 2.0.4 (from Fedora Core 3 testing updates), and it seems to
lock up whether I synchronize or copy from evo (same with evo 2.0.2).

Here is the output from gpilotd when this happens:
ecalconduit-Message: ---------------------------------------------------------

ecalconduit-Message: pre_sync: Calendar Conduit v.0.1.6
ecalconduit-Message:   Using timezone:
/softwarestudio.org/Olson_20011030_5/America/New_York

I'm trying to sync to a Treo650, which works with local calendars.

I've tried manually upgrading to evo 2.2.0 (rebuilt all appropriate rpms from
Fedora 4 test), but to no avail- that seemed to be less stable.
Comment 4 Aaron Gaudio 2005-03-22 10:05:50 EST
Created attachment 112214 [details]
Patch to fix broken pilot synchronization

I believe I have solved this. Try this patch out.
Comment 5 Gary Mansell 2005-05-06 05:55:11 EDT
I see this problem on RHEL 4 and it is causing me not to be able to sync my Palm
pilot with Evolution running with the Connector. It appears to be the calendar
that causes the problem.

What do I do about resolving the problem - I would guess that the patch supplied
has to be applied to a source rpm (which one) and are there any instructions
anywhere regarding doing this?

Is it likely to be fixed in the near future - ie is the next update of evolution
going to resolve this problem so that I can just up2date away from the problem?
Comment 6 Aaron Gaudio 2005-05-10 17:42:56 EDT
Gary, the patch above should be applied to Ximian Connector (in the Fedora
'evolution-connector' srpm. To do it manually, download the evolution-connector
rpm for FC3, install it, then edit the spec file to add my patch, as per the RPM
spec format. Then rebuild the rpm with 'rpmbuild -ba evolution-connector.spec'.

BTW, this is really a bug with evolution-connector, not gnome-pilot or the conduits.
Comment 7 Gary Mansell 2005-05-11 04:09:28 EDT
I have tried this and installed the new RPM but it has not fixed the problem.

Any ideas what I do to get Redhat to fix this in RHEL as it is a real nuisance
not to be able to sync with my Palm Pilot?
Comment 8 Dave Malcolm 2005-05-11 23:37:28 EDT
Thanks.  The patch looks good to me; I'm working on a test FC-3 update for this.

It looks like the bug persists upstream, so this will affect FC-4 as well; I'll
help with getting this committed upstream.

Gary Mansell: It may be that the problems you're encountering are this bug, or
that you're seeing a different bug (or perhaps a combination).  I recommend
opening an issue with Red Hat Support so that we can be sure that we get the
problems you're seeeing fixed.
https://www.redhat.com/apps/support/
It will help us if you cite this bugzilla ID for reference when you do.

I've marked the problem identified by Aaron Gaudio as a candidate for inclusion
in a RHEL 4 quarterly update.  Please open an issue with Red Hat Support if you
want a faster fix, or information on exactly when the update will be available.

I hope this answers your questions
Comment 9 Dave Malcolm 2005-05-12 00:30:01 EDT
I've released a test update for FC3 containing the patch:
https://www.redhat.com/archives/fedora-test-list/2005-May/msg00457.html
Comment 10 Aaron Gaudio 2005-05-18 10:25:05 EDT
Dave,

My patch also applies cleanly to connector 2.2.2 (in Fedora Core 4 Test), which
also appears to have the same problem.
Comment 11 Dave Malcolm 2005-05-18 12:27:09 EDT
Thanks!  

Has anyone tried the the FC3 test package?

I'm trying to get your patch into the FC4 package before release.

I added some notes to the upstream bug, in the hope of getting this fixed there
as well.
Comment 13 Dave Malcolm 2005-06-17 20:37:37 EDT
Has anyone tried the FC3 test package?
https://www.redhat.com/archives/fedora-test-list/2005-May/msg00457.html
Comment 14 Dave Malcolm 2005-06-20 14:38:20 EDT
(I created bug 161133 to track this bug for RHEL 4)
Comment 16 Dave Malcolm 2005-08-29 14:23:30 EDT
This is now available as a full update for FC3:
https://www.redhat.com/archives/fedora-announce-list/2005-August/msg00124.html

Note You need to log in before you can comment on or make changes to this bug.