Bug 1394027 - [RFE] Backwards compatibility with previous version [for RHOSP11]
Summary: [RFE] Backwards compatibility with previous version [for RHOSP11]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates-compat
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Adriano Petrich
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks: 1426493
TreeView+ depends on / blocked
 
Reported: 2016-11-10 20:54 UTC by Jaromir Coufal
Modified: 2017-05-17 19:46 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-compat-5.2.0-7.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:46:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Jaromir Coufal 2016-11-10 20:54:23 UTC

Comment 1 Jaromir Coufal 2016-11-10 20:55:56 UTC
USER STORIES:

* As a cloud operator, I want to have accessible and operable cloud (v10) with upgraded RHOSP director (v11) so that I can upgrade in stages.

* As a cloud operator, I want to deploy RHOSP 10 with RHOSP director 11 so that I can use new drivers from Ironic.

Comment 2 Jaromir Coufal 2016-12-14 19:53:19 UTC
Mostly testing effort.

Comment 11 Raviv Bar-Tal 2017-05-15 08:50:03 UTC
In order to cove this RFE we have tested the following scenarios:
1. Deploy Newton Undercloud and overcloud, Update Undercloud only and perform scaling procedures using saved Newton heat tamplates (add and remove compute node).
2. Deploy new Ocata Undercloud and use the "compat" heat template (rpm openstack-tripleo-heat-templates-compat) to deploy new Newton overcloud and scale this cloud (add  and remove compute nodes).


The above scenarios were tested on:
1. Non HA overcloud (1 controller, 1 compute) 
2. HA overcloud (3 controllers , 2 computes, 3 ceph)
3. Composable networker HA overcloud (3 controllers , 2 computes, 2 netwrokers)

Comment 12 errata-xmlrpc 2017-05-17 19:46:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.