Bug 139404 - Octave occasionally hangs
Octave occasionally hangs
Status: CLOSED DUPLICATE of bug 138447
Product: Fedora
Classification: Fedora
Component: lapack (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 15:49 EST by Ed Friedman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2004-11-15 15:49:57 EST
Description of problem:
Octave hangs on some eigenvalue calculations.

Version-Release number of selected component (if applicable):
octave-2.1.57-7

How reproducible:
Always

Steps to Reproduce:
1.Start octave and enter:  a=1:5
2.Enter:  b=a'*a
3.Enter:  [v,l]=eig(b)
  
Actual results:
Computer hangs

Expected results:
The result should be:
v =
 
    1.8492e-01    8.9443e-01   -3.8402e-01    1.2348e-02    1.3484e-01
    3.6984e-01   -4.4721e-01   -7.6804e-01    2.4695e-02    2.6968e-01
   -4.0101e-01   -3.5488e-18   -7.7371e-02   -8.1827e-01    4.0452e-01
    6.6458e-01    3.4962e-17    5.0596e-01   -1.0689e-01    5.3936e-01
   -4.7598e-01    3.1257e-19    2.5671e-02    5.6413e-01    6.7420e-01
 
l =
 
   -0.00000    0.00000    0.00000    0.00000    0.00000
    0.00000   -0.00000    0.00000    0.00000    0.00000
    0.00000    0.00000    0.00000    0.00000    0.00000
    0.00000    0.00000    0.00000    0.00000    0.00000
    0.00000    0.00000    0.00000    0.00000   55.00000

Additional info:
The same code works fine in Fedora 1 and in Fedora 2.
Comment 1 Lon Hohberger 2004-11-15 16:59:07 EST
Hmm, probably some change octave 2.1.50 and octave-2.1.57.
Comment 2 Lon Hohberger 2004-11-17 15:59:22 EST
Happens on 2.1.62...
Comment 3 Ed Friedman 2004-11-18 12:20:11 EST
It's not so simple as a change in octave between versions.  I tried
removing the 2.1.57 rpm and installed the 2.1.50 rpm and it still
doesn't work on Fedora 3 (but does work on Fedora2).  Could this be a
library problem?
Comment 4 Lon Hohberger 2004-11-18 12:25:05 EST
Yes; I actually tried on 2.1.62 and 2.1.50.  I think it's a problem in
the lapack library.
Comment 5 Ivana Varekova 2005-01-10 09:59:22 EST
I think it's lapack problem.
Comment 6 Ivana Varekova 2005-01-10 10:03:43 EST

*** This bug has been marked as a duplicate of 138447 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:07:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.