Bug 1394154 - [abrt] gnome-terminal: wl_abort(): gnome-terminal-server killed by SIGABRT
Summary: [abrt] gnome-terminal: wl_abort(): gnome-terminal-server killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1466654
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8117e3102ff51c7d81b295feb60...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-11 08:43 UTC by Mikhail
Modified: 2017-09-24 20:09 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-24 19:27:19 UTC


Attachments (Terms of Use)
File: backtrace (39.01 KB, text/plain)
2016-11-11 08:43 UTC, Mikhail
no flags Details
File: cgroup (276 bytes, text/plain)
2016-11-11 08:43 UTC, Mikhail
no flags Details
File: core_backtrace (6.97 KB, text/plain)
2016-11-11 08:43 UTC, Mikhail
no flags Details
File: dso_list (10.28 KB, text/plain)
2016-11-11 08:43 UTC, Mikhail
no flags Details
File: environ (1.04 KB, text/plain)
2016-11-11 08:43 UTC, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2016-11-11 08:43 UTC, Mikhail
no flags Details
File: maps (55.98 KB, text/plain)
2016-11-11 08:44 UTC, Mikhail
no flags Details
File: mountinfo (3.86 KB, text/plain)
2016-11-11 08:44 UTC, Mikhail
no flags Details
File: namespaces (102 bytes, text/plain)
2016-11-11 08:44 UTC, Mikhail
no flags Details
File: open_fds (2.15 KB, text/plain)
2016-11-11 08:44 UTC, Mikhail
no flags Details
File: proc_pid_status (1.12 KB, text/plain)
2016-11-11 08:44 UTC, Mikhail
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-11-11 08:44 UTC, Mikhail
no flags Details
system log (411.52 KB, text/x-vhdl)
2017-01-04 11:43 UTC, Mikhail
no flags Details
screenshot (426.43 KB, image/png)
2017-01-04 11:44 UTC, Mikhail
no flags Details

Description Mikhail 2016-11-11 08:43:46 UTC
Description of problem:
close Google Chrome

Version-Release number of selected component:
gnome-terminal-3.22.1-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     2305
kernel:         4.8.6-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 wl_abort at src/wayland-util.c:418
 #3 wl_proxy_marshal_array_constructor_versioned at src/wayland-client.c:659
 #4 wl_proxy_marshal_array_constructor at src/wayland-client.c:599
 #5 wl_proxy_marshal at src/wayland-client.c:696
 #6 wl_surface_damage at /usr/include/wayland-client-protocol.h:3478
 #7 gdk_window_impl_wayland_end_paint at gdkwindow-wayland.c:934
 #8 gdk_window_end_paint_internal at gdkwindow.c:3000
 #9 gdk_window_end_draw_frame at gdkwindow.c:3268
 #10 gtk_widget_render at gtkwidget.c:17502
 #11 gtk_main_do_event at gtkmain.c:1813

Potential duplicate: bug 1371608

Comment 1 Mikhail 2016-11-11 08:43:52 UTC
Created attachment 1219659 [details]
File: backtrace

Comment 2 Mikhail 2016-11-11 08:43:53 UTC
Created attachment 1219660 [details]
File: cgroup

Comment 3 Mikhail 2016-11-11 08:43:55 UTC
Created attachment 1219661 [details]
File: core_backtrace

Comment 4 Mikhail 2016-11-11 08:43:57 UTC
Created attachment 1219662 [details]
File: dso_list

Comment 5 Mikhail 2016-11-11 08:43:58 UTC
Created attachment 1219663 [details]
File: environ

Comment 6 Mikhail 2016-11-11 08:43:59 UTC
Created attachment 1219664 [details]
File: limits

Comment 7 Mikhail 2016-11-11 08:44:03 UTC
Created attachment 1219665 [details]
File: maps

Comment 8 Mikhail 2016-11-11 08:44:04 UTC
Created attachment 1219666 [details]
File: mountinfo

Comment 9 Mikhail 2016-11-11 08:44:06 UTC
Created attachment 1219667 [details]
File: namespaces

Comment 10 Mikhail 2016-11-11 08:44:08 UTC
Created attachment 1219668 [details]
File: open_fds

Comment 11 Mikhail 2016-11-11 08:44:09 UTC
Created attachment 1219669 [details]
File: proc_pid_status

Comment 12 Mikhail 2016-11-11 08:44:11 UTC
Created attachment 1219670 [details]
File: var_log_messages

Comment 13 Peter Jones 2016-11-14 16:53:01 UTC
Similar problem has been detected:

I thought ~/.bin/noarch/hub was probably a short shell script, so I
'cat'ed it.  gnome-terminal crashed, as shows up in the log, but it
appears as if the compositor also restarted.  This is with an Xwayland
session.

FWIW: 

trillian:~$ ldd `which gnome-terminal` | grep '=>' | cut '-d>' -f2 | cut
-d\  -f2 | xargs rpm -qf  | sort -u
at-spi2-atk-2.22.0-1.fc25.x86_64
at-spi2-core-2.22.0-1.fc25.x86_64
atk-2.22.0-1.fc25.x86_64
bzip2-libs-1.0.6-20.fc24.x86_64
cairo-1.14.6-2.fc25.x86_64
cairo-gobject-1.14.6-2.fc25.x86_64
dbus-libs-1.11.6-1.fc25.x86_64
dconf-0.26.0-1.fc25.x86_64
expat-2.2.0-1.fc25.x86_64
fontconfig-2.12.1-1.fc25.x86_64
freetype-2.6.5-1.fc25.x86_64
gdk-pixbuf2-2.36.0-1.fc25.x86_64
glib2-2.50.1-1.fc25.x86_64
glibc-2.24-3.fc25.x86_64
gmp-6.1.1-1.fc25.x86_64
gnutls-3.5.5-2.fc25.x86_64
graphite2-1.3.6-1.fc25.x86_64
gtk3-3.22.2-1.fc25.x86_64
harfbuzz-1.3.2-1.fc25.x86_64
libX11-1.6.4-1.fc25.x86_64
libXau-1.0.8-6.fc24.x86_64
libXcomposite-0.4.4-8.fc24.x86_64
libXcursor-1.1.14-6.fc24.x86_64
libXdamage-1.1.4-8.fc24.x86_64
libXext-1.3.3-4.fc24.x86_64
libXfixes-5.0.3-1.fc25.x86_64
libXi-1.7.8-2.fc25.x86_64
libXinerama-1.1.3-6.fc24.x86_64
libXrandr-1.5.1-1.fc25.x86_64
libXrender-0.9.10-1.fc25.x86_64
libXxf86vm-1.1.4-3.fc24.x86_64
libblkid-2.28.2-1.fc25.x86_64
libcap-2.25-2.fc25.x86_64
libdatrie-0.2.9-3.fc25.x86_64
libdrm-2.4.71-2.fc25.x86_64
libepoxy-1.3.1-3.fc25.x86_64
libffi-3.1-9.fc24.x86_64
libgcc-6.2.1-2.fc25.x86_64
libgcrypt-1.6.6-1.fc25.x86_64
libgpg-error-1.24-1.fc25.x86_64
libidn-1.33-1.fc25.x86_64
libmount-2.28.2-1.fc25.x86_64
libpng-1.6.23-1.fc25.x86_64
libselinux-2.5-12.fc25.x86_64
libstdc++-6.2.1-2.fc25.x86_64
libtasn1-4.9-1.fc25.x86_64
libthai-0.1.25-1.fc25.x86_64
libuuid-2.28.2-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64
libwayland-cursor-1.12.0-1.fc25.x86_64
libwayland-server-1.12.0-1.fc25.x86_64
libxcb-1.12-1.fc25.x86_64
libxkbcommon-0.6.1-1.fc25.x86_64
libxshmfence-1.2-3.fc24.x86_64
lz4-r131-2.fc24.x86_64
mesa-libEGL-12.0.3-3.fc25.x86_64
mesa-libGL-12.0.3-3.fc25.x86_64
mesa-libgbm-12.0.3-3.fc25.x86_64
mesa-libglapi-12.0.3-3.fc25.x86_64
mesa-libwayland-egl-12.0.3-3.fc25.x86_64
nettle-3.3-1.fc25.x86_64
p11-kit-0.23.2-2.fc24.x86_64
pango-1.40.3-1.fc25.x86_64
pcre-8.39-6.fc25.x86_64
pcre2-10.22-5.fc25.x86_64
pixman-0.34.0-2.fc24.x86_64
systemd-libs-231-10.fc25.x86_64
vte291-0.46.0-2.fc25.x86_64
xz-libs-5.2.2-2.fc24.x86_64
zlib-1.2.8-10.fc24.x86_64

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     19408
kernel:         4.8.5-300.fc25.x86_64
package:        gnome-terminal-3.22.0-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            2174

Comment 14 Mikhail 2016-12-16 17:22:53 UTC
Similar problem has been detected:

Crash occured when Google Chrome consume a lot of memory

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     2126
kernel:         4.8.14-300.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Mikhail 2017-01-04 11:43:26 UTC
Created attachment 1237098 [details]
system log

Comment 16 Mikhail 2017-01-04 11:44:23 UTC
Created attachment 1237099 [details]
screenshot

Comment 17 Štefan Gurský 2017-01-09 12:39:27 UTC
Similar problem has been detected:

I can reproduce this (using midnight commander)
1. Create fairly large tar archive with binary content but do not give it "tar.gz" extension. Doing „tar czf foo /usr/bin“ works
2. run midnight commander (mc) in gnome-terminal
3. move the cursor to the file and press enter. The file is displayed for a short while and then terminal crashes.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     12218
kernel:         4.8.15-300.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 18 Štefan Gurský 2017-01-09 12:51:56 UTC
Well, just running cat on large enough binary file crashes the terminal (for example /usr/bin/dockerd-current from docker package: 29 MB). And if I do
cat /usr/bin/bash
the system freezes for a short while and then I get 

bash: 62: command not found...

bash: c: command not found...

and the last line in history is
62;c
which is kind of scary. This happens in dash too (but not in zsh) in gnome-terminal.

In xterm after running cat /usr/bin/bash I get commandline with
64;1;2;6;9;15;18;2164;1;2;6;9;15;18;21;22c
but it is not submitted.

Comment 19 Peter 2017-01-18 06:31:37 UTC
Similar problem has been detected:

I accidentally tried to edit a lager xz file in mc.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     17616
kernel:         4.9.3-200.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 20 Alan Jenkins 2017-01-23 11:39:09 UTC
Similar problem has been detected:

rpm2cpio policycoreutils-2.5-19.fc25.src.rpm

(I assume this wrote cpio data to the terminal, which is not quite what I mean).

Terminal bell rings continuouslly, no extra output is visible in terminal, and then it crashes

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     5047
kernel:         4.9.4-201.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 21 Alan Jenkins 2017-01-23 11:46:14 UTC
Here is the file to reproduce my command "rpm2cpio policycoreutils-2.5-19.fc25.src.rpm".  https://dl.dropboxusercontent.com/u/49925445/bugzilla.redhat.com/1394154/policycoreutils-2.5-19.fc25.src.rpm

Comment 22 Mikhail 2017-03-10 14:25:51 UTC
Similar problem has been detected:

Occured when I lauch Google Chrome with overhemly large count of tabs

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     2107
kernel:         4.9.13-201.fc25.x86_64+debug
package:        gnome-terminal-3.22.1-5.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 23 Arne 2017-03-12 11:53:08 UTC
Similar problem has been detected:

accidentally executed the cat command on a binary file (8MB)

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     1855
kernel:         4.9.13-201.fc25.x86_64
package:        gnome-terminal-3.22.1-5.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 24 Olivier Crête 2017-05-02 17:01:25 UTC
Similar problem has been detected:

I did "cat" with a H.264 stream.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: wl_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     15511
kernel:         4.9.14-200.fc25.x86_64
package:        gnome-terminal-3.22.1-5.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            500

Comment 25 Debarshi Ray 2017-09-24 19:27:19 UTC

*** This bug has been marked as a duplicate of bug 1466654 ***


Note You need to log in before you can comment on or make changes to this bug.