Bug 139419 - satellite-sync issue (ORA-01403: no data found)
satellite-sync issue (ORA-01403: no data found)
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Max Spevack
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-11-15 16:54 EST by Max Spevack
Modified: 2007-07-31 11:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 09:05:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-11-15 16:54:47 EST
Description of problem:

During a satellite-sync on a rhel3 box to QA:

16:55:57    Importing *relevant* errata: rhel-i386-as-3 (7)
            ________________________________________
Downloading:+++ sending log as an email +++
 
SYNC ERROR: unhandled exception occurred:
 
(Check logs/email for potentially more detail)
 
(1403, 'ORA-01403: no data found\nORA-06512: at
"RHNSAT.RHN_ERRATA_FILE_DEL_TRIG", line 8\nORA-04088: error during
execution of trigger \'RHNSAT.RHN_ERRATA_FILE_DEL_TRIG\'\n', 'delete
from rhnErrataFile where errata_id = :errata_id and filename = :filename')

Version-Release number of selected component (if applicable):
3.6

Text of the email sent to me:

16:55:58
SYNC ERROR: unhandled exception occurred:
                                                                     
                              
Exception reported from rhnblade4.rhndev.redhat.com
Time: Mon Nov 15 16:55:58 2004
Exception type server.rhnSQL.sql_base.SQLError
                                                                     
                              
Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 128, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 154, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 257, in
_step_errata
    self.syncer.import_errata()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1645, in
import_errata
    sync_handlers.import_errata(chunk)
  File "/usr/share/rhn/satellite_tools/sync_handlers.py", line 403, in
import_errata
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 541, in run
    self.submit()
  File "/usr/share/rhn/server/importlib/errataImport.py", line 163, in
submit
    self.backend.processErrata(self.batch)
  File "/usr/share/rhn/server/importlib/backend.py", line 559, in
processErrata
    transactional=1)
  File "/usr/share/rhn/server/importlib/backend.py", line 970, in
__processObjectCollection
    self.__doDML(dml)
  File "/usr/share/rhn/server/importlib/backend.py", line 1072, in __doDML
    self.__doDelete(dml.delete, dml.tables)
  File "/usr/share/rhn/server/importlib/backend.py", line 1099, in
__doDelete
    self.__doDeleteTable(tname, dict)
  File "/usr/share/rhn/server/importlib/backend.py", line 1109, in
__doDeleteTable
    deleteObj.query(hash)
  File "/usr/share/rhn/server/importlib/backendLib.py", line 309, in query
    executeStatement(statement, val, self.count)
  File "/usr/share/rhn/server/importlib/backendLib.py", line 331, in
executeStatement
    count = count + apply(statement.executemany, (), tempdict)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 102, in
executemany
    return apply(self._execute_wrapper, (self._executemany, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 131, in
_execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (1403, 'ORA-01403: no data found\nORA-06512: at
"RHNSAT.RHN_ERRATA_FILE_DEL_TRIG",
line 8\nORA-04088: error during execution of trigger
\'RHNSAT.RHN_ERRATA_FILE_DEL_TRIG\'\n',
'delete from rhnErrataFile where errata_id = :errata_id and filename =
:filename')
Comment 1 Mihai Ibanescu 2004-11-15 18:21:53 EST
Peter, can you have a look? This shouldn't be something I'd have to
fix in the code...
Comment 2 Peter Jones 2004-11-15 18:35:58 EST
This looks like what was fixed in revision 1.4 on 11/10... you're sure
the sat is running the newest schema?
Comment 3 Max Spevack 2004-11-16 09:05:43 EST
I was running the wrong schema.

Note You need to log in before you can comment on or make changes to this bug.