Bug 139425 - Regression: Radeon driver no longer detects second monitor successfully
Regression: Radeon driver no longer detects second monitor successfully
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 17:13 EST by Darryl Dixon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:27:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl Dixon 2004-11-15 17:13:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Using FC3 on an IBM R40 laptop with Radeon Mobility M6 graphics chip,
with external monitor attached.  The move from xorg 6.7 to 6.8 has
broken the detection of the laptop panel as the primary display for
Xinerama dual-head.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1.Install FC2 and configure for dual-head
2.Upgrade to FC3 (OR just install Xorg 6.8 from CVS head)
3.Test dual-head (is broken)
    

Actual Results:  Desktop only gets drawn on the external monitor, and
the laptop panel turns off.

Expected Results:  The desktop should span both the laptop panel and
the external monitor.

Additional info:

This is an upstream bug specifically in the Xorg 6.8 server.  It is
not present in Xorg 6.7.  If you copy back the ati_drv.o and
radeon_drv.o files from 6.7 after installing 6.8 the problem goes
away.  I'm marking this as high as this is a regression and will be a
showstopper for many people.
Comment 1 Philip Van Hoof 2004-11-16 18:05:05 EST
#138500 might be related
Comment 2 Mike A. Harris 2005-02-07 22:45:06 EST
Please update to xorg-x11 from rawhide, and indicate if the
problem is resolved in the new xorg or not.  If the problem
persists, please attach your X server log file and config file
to the report as individual uncompressed file attachments.

Comment 3 Mike A. Harris 2005-02-07 22:45:58 EST
Setting status to "NEEDINFO", awaiting testing of xorg-x11 from
rawhide, and files requested in comment #2 above.
Comment 4 Mike A. Harris 2005-04-15 10:27:34 EDT
This bug has not been updated to provide us with the information
we've requested above.  If you have not already updated to the
latest Fedora Core xorg-x11 and kernel updates, please do so now and
if you still encounter the problem described above, please report the
issue to X.Org bugzilla at http://bugs.freedestop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NOTABUG" due to lack of information.


Note You need to log in before you can comment on or make changes to this bug.