Bug 1394290 - Could not find virtual machine network interface matching <ip address>
Summary: Could not find virtual machine network interface matching <ip address>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - VMWare
Version: 6.2.4
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Sanket Jagtap
URL:
Whiteboard:
Depends On:
Blocks: 1417070
TreeView+ depends on / blocked
 
Reported: 2016-11-11 15:09 UTC by Waldirio M Pinheiro
Modified: 2023-09-15 00:00 UTC (History)
19 users (show)

Fixed In Version: foreman-1.11.0.66-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1417070 (view as bug list)
Environment:
Last Closed: 2017-03-06 08:34:36 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
patch to foreman to add more logging around vsphere networks. (1.45 KB, application/mbox)
2016-11-16 16:39 UTC, Ivan Necas
no flags Details
patch to foreman to change the way we identify the the network, when virtual switches in place. (3.14 KB, application/mbox)
2016-11-16 16:41 UTC, Ivan Necas
no flags Details
output query (67.89 KB, application/pdf)
2016-11-18 14:57 UTC, Waldirio M Pinheiro
no flags Details
patch to foreman to change the way we identify the the network to use key instead of managed object id (1.02 KB, patch)
2016-11-18 19:48 UTC, Ivan Necas
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 11106 0 Normal Closed Foreman 1.8.2 with VMware errors with: Could not find virtual machine network interface matching x.x.x.x 2020-12-14 14:48:29 UTC
Red Hat Knowledge Base (Solution) 2891241 0 None None None 2017-01-27 06:20:25 UTC
Red Hat Product Errata RHBA-2017:0447 0 normal SHIPPED_LIVE Satellite 6.2.8 Async Bug Release 2017-03-06 13:23:41 UTC

Description Waldirio M Pinheiro 2016-11-11 15:09:41 UTC
Description of problem:
When customer try to provision new machines using distributed switch on vCenter they receive this message, although it's possible to provision using Standard switch.

Version-Release number of selected component (if applicable):
6.2.2 (customer environment)

Ps.: This customer came from 6.1.9 -> 6.2.2

How reproducible:
100% in customer env.

Steps to Reproduce:
1. Create new host
2. Define all information about vm
3. Define the network to one specific distributed SW
4. Submit

Actual results:
Message below
---
Unable to save
Could not find virtual machine network interface matching 10.0.10.238
---

Expected results:
Provision a new machine.

Additional info:

Comment 2 Waldirio M Pinheiro 2016-11-11 15:32:19 UTC
Hello all

Just one information about the project
 - http://projects.theforeman.org/issues/11106


Best Regards
-- 
Waldirio M Pinheiro | Senior Software Maintenance Engineer

Comment 7 Bryan Kearney 2016-11-11 16:47:55 UTC
Connecting redmine issue http://projects.theforeman.org/issues/11106 from this bug

Comment 9 Bryan Kearney 2016-11-11 17:12:07 UTC
Upstream bug component is Compute Resources - VMWare

Comment 21 Ivan Necas 2016-11-16 16:39:34 UTC
Created attachment 1221290 [details]
patch to foreman to add more logging around vsphere networks.

patch to foreman to add more logging around vsphere networks. To apply:

cd /usr/share/foreman
git init; git add -A .; git commit -m original
patch -p1 < ~/vsphere-net-logging.patch
service httpd restart

Tested against sat 6.2.4, but should work with any 6.2.x version

Comment 22 Ivan Necas 2016-11-16 16:41:15 UTC
Created attachment 1221291 [details]
patch to foreman to change the way we identify the the network, when virtual switches in place.

patch to foreman to change the way we identify the the network, when virtual switches in place. To apply:

cd /usr/share/foreman
git init; git add -A .; git commit -m original
patch -p1 < ~/vsphere-net-logging.patch
service httpd restart

Tested against sat 6.2.4, but should work with any 6.2.x version

Comment 23 Ivan Necas 2016-11-16 16:42:44 UTC
And of course, the second patch should have different name, such as vsphere-unique-networks.patch

cd /usr/share/foreman
git init; git add -A .; git commit -m original
patch -p1 < vsphere-unique-networks.patch
service httpd restart

Comment 24 Ivan Necas 2016-11-16 16:46:05 UTC
I would like to ask to apply first the logging patch, try to provision, then the second one and try to provision again and at the end share /var/log/foreman/production.log with us

Comment 37 Waldirio M Pinheiro 2016-11-18 14:57:50 UTC
Created attachment 1221886 [details]
output query

Comment 40 Ivan Necas 2016-11-18 19:48:36 UTC
Created attachment 1222001 [details]
patch to foreman to change the way we identify the the network to use key instead of managed object id

patch to foreman to change the way we identify the the network to use network key instead of the managed object id.

Please revert changes caused by previous patches attached to the bz first (as mentioned in the instructions below)

cd /usr/share/foreman
# in case not already managed by git
git init; git add -A .; git commit -m original
# in case some local changes were made before
git checkout -- .
patch -p1 < ~/vsphere-dvportgroup-key.patch
service httpd restart

Comment 50 Bryan Kearney 2016-11-28 23:12:09 UTC
Upstream bug assigned to inecas

Comment 51 Bryan Kearney 2016-11-28 23:12:14 UTC
Upstream bug assigned to inecas

Comment 64 errata-xmlrpc 2017-03-06 08:34:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0447

Comment 66 Red Hat Bugzilla 2023-09-15 00:00:30 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 500 days


Note You need to log in before you can comment on or make changes to this bug.