Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1394395 - Create /var/lib/nfs/etab etc if they don't exist
Create /var/lib/nfs/etab etc if they don't exist
Status: CLOSED DUPLICATE of bug 1293933
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-11 15:46 EST by Colin Walters
Modified: 2016-11-11 16:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-11 16:52:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2016-11-11 15:46:11 EST
For rpm-ostree as used by Atomic Host, we synthesize tmpfiles.d snippets for directories, but not files.

The goal here is that one can perform a "factory reset" by rm -rf /var/* && systemctl reboot.

So currently this requires one to:
touch /var/lib/nfs/{etab,rmtab}

I think the simplest is to change the code to create the file on demand if it doesn't exist.  Failing that, a systemd tmpfiles.d `f` entry would work fine.

It's possible at some point we'll explicitly special case nfs-utils in rpm-ostree to do this, but I'd like to have nfs-utils learn about this as well.
Comment 2 Colin Walters 2016-11-11 16:52:03 EST

*** This bug has been marked as a duplicate of bug 1293933 ***

Note You need to log in before you can comment on or make changes to this bug.