Bug 139457 - crash "preparing RPM transaction" after 12% complete
crash "preparing RPM transaction" after 12% complete
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-11-15 21:45 EST by Myk Melez
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-01 22:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Myk Melez 2004-11-15 21:45:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Upgrading my laptop from FC2 to FC3 crashes when the "Preparing RPM
transaction..." stage is 12% complete.  The console tells me "install
exited abnormally" and shuts down the system.  The anaconda log
console ends with the following two items:

* moving (1) to step installpackages
* setting file_context_path to

How reproducible:

Steps to Reproduce:
1. boot from FC3 disk 1 and go through the pre-installation wizard,
electing to upgrade an existing FC2 installation;
2. when prompted to click next to begin upgrade of system, click next;
3. crash.

Actual Results:  The installer crashes.

Expected Results:  The installer successfully upgrades my FC2
installation to FC3.

Additional info:

It happens in both graphical and text installation modes and with two
different (both verified) FC3 disk 1 CDs.

I have no external peripherals hooked up to the system (i.e. no mice,
keyboards, or PC cards).

The following message appears before "install exited abnormally" in my
log (but it gets written to the log earlier in the upgrade process,
not right when the crash occurs):

warning: package kernel = 2.6.9-1.667 was already added, replacing
with kernel <= 2.6.9-1.667.
Comment 1 Jeremy Katz 2004-11-16 12:02:23 EST
Were you using selinux with fc2?
Comment 2 Myk Melez 2004-11-17 09:14:47 EST
I haven't been using selinux with FC2, although I think it was enabled
at some point.  As I recall, earlier this year (perhaps right after I
installed FC2) I noticed selinux was on and turned it off in
/etc/sysconfig/selinux, which seemed to be the preferred method
according to a Google search at the time (see also bug 129240):

myk@myk myk]$ more /etc/sysconfig/selinux
# This is a comment field in /etc/sysconfig/selinux
# Allowable values are:
#     enforcing  -  enables enforcing mode
#     permissive -  enables permissive mode
#     disabled   -  disables SELinux
[myk@myk myk]$

I'm running a recent FC2 kernel, so I should be unaffected by the bug
in the original FC2 kernel (documented in bug 129240) that caused
selinux to run even if disabled:

[myk@myk myk]$ uname -a
Linux myk.office.mozilla.org 2.6.8-1.521 #1 Mon Aug 16 09:01:18 EDT
2004 i686 i686 i386 GNU/Linux

I'm not sure if this means anything, but note that I still get
selinux-related messages when upgrading packages, even though selinux
is supposedly not running:

[myk@myk myk]$ sudo yum update
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading Packages
Running test transaction:
/etc/security/selinux/file_contexts: No such file or directory
Test transaction complete, Success!
/etc/security/selinux/file_contexts: No such file or directory
glibc-common 100 % done 1/20
glibc 100 % done 2/20
Comment 3 Myk Melez 2004-11-17 09:26:30 EST
Sorry about the inadvertant QA contact removal.  It looks like a bug
in this Bugzilla installation (bug 132004 to be precise).  Adding the
QA contact back in.
Comment 4 Jeremy Katz 2004-11-17 10:06:49 EST
Does booting with 'linux selinux=0' work?
Comment 5 Myk Melez 2004-11-18 18:04:36 EST
If I boot with 'linux selinux=0' it crashes at the same place, but the
last two lines on the anaconda console are instead:

moving (1) to step installpackages
setting file_context_path to nil
Comment 6 Steve Wendt 2004-11-21 07:00:56 EST
I have the same problem, and the same results, both normally and with
selinux=0 (except mine isn't a laptop).  However, mine gets a bit
further - it consistently dies at 40% on the "Preparing to install..."
progress bar.

Booting back into FC2, /root/upgrade.log* are 0 bytes, so I'm not sure
what else I can look at.
Comment 7 Myk Melez 2004-11-23 18:21:42 EST
What's the best way to debug anaconda?

I tried hacking its Python scripts with debugging statements before
kicking off the install to try to determine where they're falling
over, but they're mounted read-only.

I also found some references on the net to updates floppies with
modified versions of installation files, but I couldn't find good docs
on creating such disks.
Comment 8 Steve Wendt 2004-12-03 04:13:12 EST
Rebuilding the RPM database seemed to fix it for me...
Comment 9 Myk Melez 2004-12-03 17:29:17 EST
I worked around the problem last night by first upgrading to FC3test2
on that machine and then upgrading to FC3 final.  The FC3test2 upgrade
succeeded without problems, and once it was on my machine I could
upgrade to FC3 final without any problems either.

Note You need to log in before you can comment on or make changes to this bug.