Bug 139461 - yum fails to differentiate between user cancel and download failure
yum fails to differentiate between user cancel and download failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 22:28 EST by Rahul Sundaram
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 22:36:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2004-11-15 22:28:03 EST
Description of problem:

yum in fc3 has a mirror switching ability when it fails to download a
particular package (presumably because the mirror was not properly
updated). unfortunately it doesnt differentiate between user cancel an
this. I try to cancel a download in the middle and it simply calls it
a IO error and switches to a new mirror.

Version-Release number of selected component (if applicable):


How reproducible:

everytime

Steps to Reproduce:
1. yum  install packge
2. control+c in the middle of a download

  
Actual results:

switches to a new mirror

Expected results:

Exit on user cancel

Additional info:
Comment 1 Rahul Sundaram 2004-11-15 22:36:12 EST
sorry. please close bug . this was caused due to accidental refresh

Note You need to log in before you can comment on or make changes to this bug.