This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 139463 - Spinning on rhgb-console
Spinning on rhgb-console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 22:43 EST by Owen Taylor
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 08:15:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2004-11-15 22:43:57 EST
http://www.redhat.com/archives/fedora-devel-list/2004-November/msg00561.html

reveals that rhgb spins at 100% cpu during boot. Some inspection
of the source code reveals this is do to the handling of
rhgb-console... it calls poll() on a fifo ... and fifo's have
the behavior that once the last writer closes the fifo, it 
reports HUP until a new reader opens it.

Googling on the topic reveals:

http://mail.gnome.org/archives/gtk-list/2002-September/msg00275.html

with an IRC snippet from myself about the topic. 

Two possible workarounds are suggested there:

 - Close the fifo and reopen it ...doesn't work here since
   we might lose data

 - open the fifo read/write so there are never 0 writers.

Basically, my conclusion has always been that fifo's are just
evil, poorly defined creatures. I think the O_RDWR hack will
work, at least on linux. I'm not sure it wouldn't be long
term to replace '> /etc/rhgb/temp/rhgb-console' with
'| rhgb-client --echo' or something.
Comment 1 Daniel Veillard 2004-11-16 04:10:32 EST
I see, ouch ... I will try to fix ASAP.

Daniel
Comment 2 Brian Long 2004-11-29 07:54:49 EST
I assume this also affects RHEL 3 U2 and beyond since rhgb is now
included.  Is that correct?  Will an update to rhgb be available
before U5?
Comment 3 Daniel Veillard 2004-11-29 08:14:10 EST
RHEL 3 U2 seems to use rhgb-0.11.2 which is not affected by that bug.
Updating to the latest doesn't sound resonnable it would require to
upgrade a number of other pieces.

Daniel
Comment 4 Daniel Veillard 2004-11-29 08:15:40 EST
The original bug has been fixed with a FC3 update rhgb-0.15.1

Daniel

Note You need to log in before you can comment on or make changes to this bug.