Bug 139467 - Dual boot (WinXPSP2/FC3) configuration fails to boot past BIOS
Dual boot (WinXPSP2/FC3) configuration fails to boot past BIOS
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Depends On:
  Show dependency treegraph
Reported: 2004-11-15 23:26 EST by Steven Erat
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-30 17:52:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steven Erat 2004-11-15 23:26:30 EST
Description of problem:

Machine will not boot past BIOS display.  Autoreboots, displays BIOS,
Autoreboot, display BIOS, etc, etc...  Does not even get to
visualization of Grub splash screen.

Loaded Knopppix 3.3 from boot CD and file system for WinXP and FC3
appear intact.

New install of FC3 final.  Dell 8600 Inspiron with Windows XP SP2 on
hda2 and 12.5 MB free space. Configured Windows as default OS during
FC3 install and set boot password option for grub.  FC3 installed to
the free space with: 1GB Swap, 4.5 GB /, 2GB /opt, 2GB /home, 2GB

Version-Release number of selected component (if applicable):

How reproducible:  

Steps to Reproduce:
1.  Install to Dell 8600 Inspiron as second OS
2.  Choose WinXP as default boot os
Actual results:
Machine does not boot past BIOS

Expected results:
A functional system able to display grub splash screen and boot either
OS on the system.

Additional info:
Comment 1 Steven Erat 2004-11-16 11:52:02 EST
More information:

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,4)
# kernel /boot/vmlinuz-version ro root=/dev/hda5
# initrd /boot/initrd-version.img
password --md5 $1$NXG3B1/H$R7cS/REM8ngkrOmtXOyno/
title Fedora Core (2.6.9-1.667)
root (hd0,4)
kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-1.667.img
title Windows XP
rootnoverify (hd0,1)
chainloader +1

# this device map was generated by anaconda
(fd0) /dev/fd0
(hd0) /dev/hda

fdisk -l

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 4864 39070048+ c W95 FAT32 (LBA)

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 6 48163+ de Dell Utility
/dev/hda2 * 7 2875 23045242+ 7 HPFS/NTFS
/dev/hda3 4407 4863 3670852+ db CP/M / CTOS / ...
/dev/hda4 2876 4406 12297757+ 5 Extended
/dev/hda5 2876 3492 4956021 83 Linux
/dev/hda6 3493 3753 2096451 83 Linux
/dev/hda7 3754 4014 2096451 83 Linux
/dev/hda8 4015 4275 2096451 83 Linux
/dev/hda9 4276 4406 1052226 82 Linux swap

Partition table entries are not in disk order
Comment 2 Jeremy Katz 2004-11-16 12:04:06 EST
What is /dev/sda?
Comment 3 Steven Erat 2004-11-16 12:55:27 EST
/dev/sda is an exteral usb storage device that I attached while booted
in Knoppix.  This was to copy data off /dev/hda5 (the / partition) so
that I can then mount the device on another machine to post here.
Comment 4 Steven Erat 2004-11-16 21:01:46 EST
I commented out the hiddenmenu option in grub.conf while booting from
the knoppix cd, but that had no change in behavior.  I then tried
other edits such as commenting out the password line, changing the
default OS, increasing the timeout, but no change occurred and no
additional info was gained.

I also ran the Diagnostics setup from the BIOS menu and it passed all
Comment 5 Steven Erat 2004-11-17 19:00:20 EST
The symptoms for this problem in FC3 were different from the symptoms
with the FC2 Dual Boot issue. In FC2 I got the grub menu, but got Disk
Read Error when booting Windows. In FC3 I was endlessly rebooting
after the BIOS screen.

However, it turns out that the solution for FC2 worked with my FC3
install. On a whim, I reinstalled FC3 choosing exactly the same
install options, but this time I started the install by specifying the
hard disk geometry garnered from the fdisk -l /dev/hda output:

Disk /dev/hda: 40.0 GB, 40007761920 bytes 255 heads, 63 sectors/track,
4864 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes

At the boot prompt for FC3 installation, I just entered "linux
/dev/hda=4864,255,63" and once the installation completed I was able
to boot both Windows XP and FC3 successfully.

I believe that this problem was reported to be fixed in FC3, but it is
obvious to me that it is not. 
Comment 6 Jim Gawlik 2004-11-18 01:51:00 EST

Would you please post both grub.conf and fdisk -l from your new
working install?

Comment 7 Steven Erat 2004-12-02 20:11:15 EST
grub.conf and fdisk -l have not changed.  

The only difference is that I specified the hard disk geometry for
/dev/hda when installing Linux.  

"linux /dev/hda=4864,255,63"
Comment 8 Matthew Miller 2006-07-10 16:49:01 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 9 John Thacker 2006-10-30 17:52:48 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.