Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1394727 - [RFE] Backport RFC standard DDNS updates support from 4.3.5 ESV version
[RFE] Backport RFC standard DDNS updates support from 4.3.5 ESV version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dhcp (Show other bugs)
7.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pavel Zhukov
Release Test Team
Ioanna Gkioka
: FutureFeature, Patch
Depends On:
Blocks: 1298243 1420851 1465887 1465928
  Show dependency treegraph
 
Reported: 2016-11-14 05:27 EST by Rupesh Patel
Modified: 2018-04-10 04:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: dhcp-4.2.5-62.el7
Doc Type: Release Note
Doc Text:
DHCP now supports standard dynamic DNS updates With this update, the DHCP server allows updating DNS records by using a standard protocol. As a result, DHCP supports standard dynamic DNS updates as described in RFC 2136: https://tools.ietf.org/html/rfc2136.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 04:00:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0658 None None None 2018-04-10 04:01 EDT

  None (edit)
Description Rupesh Patel 2016-11-14 05:27:43 EST
Only "ad-hoc" and "interim" DDNS updates are  available in the RHEL 7 dhcp-4.2.X.
4.3.5 ESV offer RFC standard DDNS updates (ddns-update-style standard; )

RedHat should rebase DHCP 4.2.X to 4.3.X ESV or give both legacy releases and the standard 4.3.X ESV one.
Comment 16 Marek Hruscak 2018-01-25 08:32:14 EST
Hi Rupesh,
can you please retest it with RHEL-7Beta compose? The patch is present there.
Comment 17 Rupesh Patel 2018-01-29 11:41:32 EST
Hi,

I have checked with customer.  Unfortunately customer has stopped using DDNS. However they mentioned that they have read RHEL7.5 release note.
They are closing service request.
Comment 18 Jan Stodola 2018-02-22 11:12:01 EST
Verified using the configuration files available from the link in comment 8.

1) server
[root@localhost ~]# rpm -q dhcp
dhcp-4.2.5-65.el7.x86_64
[root@localhost ~]# grep ddns-update-style /etc/dhcp/dhcpd.conf 
ddns-update-style standard;
[root@localhost ~]#

2) client
[root@localhost ~]# dhclient -H test2 ens9
[root@localhost ~]# nslookup test2.example.com
Server:		192.168.78.1
Address:	192.168.78.1#53

Name:	test2.example.com
Address: 192.168.78.10

[root@localhost ~]#

3) server logs:
named[20184]: client 192.168.78.1#39542/key rndc-key: signer "rndc-key" approved
named[20184]: client 192.168.78.1#39542/key rndc-key: updating zone 'example.com/IN': adding an RR at 'test2.example.com' A
named[20184]: client 192.168.78.1#39542/key rndc-key: updating zone 'example.com/IN': adding an RR at 'test2.example.com' DHCID
dhcpd[20124]: DHCPREQUEST for 192.168.78.10 from 52:54:00:50:a8:01 via ens9
dhcpd[20124]: DHCPACK on 192.168.78.10 to 52:54:00:50:a8:01 (test2) via ens9
dhcpd[20124]: Added new forward map from test2.example.com to 192.168.78.10
named[20184]: client 192.168.78.1#39542/key rndc-key: signer "rndc-key" approved
named[20184]: client 192.168.78.1#39542/key rndc-key: updating zone '78.168.192.in-addr.arpa/IN': deleting rrset at '10.78.168.192.in-addr.arpa' PTR
named[20184]: client 192.168.78.1#39542/key rndc-key: updating zone '78.168.192.in-addr.arpa/IN': adding an RR at '10.78.168.192.in-addr.arpa' PTR
dhcpd[20124]: Added reverse map from 10.78.168.192.in-addr.arpa. to test2.example.com
named[20184]: zone 78.168.192.in-addr.arpa/IN: sending notifies (serial 15)

Tested with dhcp-4.2.5-65.el7.

Moving to VERIFIED.
Comment 21 errata-xmlrpc 2018-04-10 04:00:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0658

Note You need to log in before you can comment on or make changes to this bug.