Bug 139474 - unable to download i386 dvd iso using rsync
unable to download i386 dvd iso using rsync
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 01:57 EST by buylinuxdvd.com
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 06:12:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description buylinuxdvd.com 2004-11-16 01:57:16 EST
Description of problem:
Unable to download i386 dvd iso usinf rsync as rsync starts with a 
negative percent download, and keep downloading even after 100% ( 
shows -110% for example)and dir listing for i386 DVD iso file shows 
file size is negative


Version-Release number of selected component (if applicable): FC3 
final

How reproducible: always

Steps to Reproduce:
dir listing of the dir containing the i386 dvd iso file
and
using rsync on windows xp, download the i386 dvd iso file from any 
rsync mirror in North America
  
Actual results:
rsync starts with a negative percent download, and keep downloading 
even after 100% 
----------------
FC3-i386-DVD.iso
2035310933 (-111%)
----------------
dir listing for i386 DVD iso file shows file size is negative
----------------
-1828556800 2004/11/04 FC3-i386-DVD.iso
----------------

Also see post on fedoraforum.org :
http://www.fedoraforum.org/forum/newreply.php?do=newreply&p=128274
Comment 1 buylinuxdvd.com 2004-11-16 02:10:36 EST
wrong url for the post on fedoraforum.org was given initially, here 
is the correct one : 
http://www.fedoraforum.org/forum/showthread.php?p=128274#post128274
Comment 2 Jay Fenlason 2004-11-16 12:43:28 EST
What version of rsync are you using under Windows XP, and why do you 
think this is a Fedora Core problem and not a problem with your 
rsync-for-windows? 
Comment 3 buylinuxdvd.com 2004-11-16 14:37:50 EST
Umm, yes it could be a problem with rsync on windows. I assumed rsync 
being a common utility would have been throughly tested inside out, 
but I guess I might be wrong.

I don't think it is a FC problem, but might be with the rsync 
mirrors? perhaps deployment of i386 dvd iso file to rsync mirrors was 
not proper or the rsync servers hosting dvd iso can't handle huge 
files?

Version of rsync I have is :
----------------------------------------------
rsync --version
rsync version 2.4.6  protocol version 24
Written by Andrew Tridgell and Paul Mackerras
---------------------------------------------

I have been able to use rsync on WinXP+SP2 for CD iso files without 
any problem. I have been able to download FC3 Test 2 using bittorrent 
with out any problem and also create dvd iso file from an existing 
distro on dvd, so I figure WinXP+SP2 can handle files of 4GB.

I dont have linux installed so I can't verify if rsync from Linux 
results in same problem, and even with Linux installed I can not get 
it to connect to my ISP so I cant provide input on that.

Search for problems with rsync for downloading dvd iso files did not 
turn up any results. I am a Linux newbie. I cant be sure where the 
problem is. I entered the bug based on my little experience with 
rsync on windows. 

My main point was to log the bug so it would get noticed. If it is a 
rsync bug I will post the defect to rsync defect database.

Let me know if I can help in narrowing the cause...
Comment 4 Jay Fenlason 2004-11-16 14:54:27 EST
That version of rsync is somewhere between old and ancient.  The 
current version of rsync is 2.6.3.  Go to wherever you got that 
version of rsync from and get a newer one.  That will probably fix 
your problem. 
Comment 5 buylinuxdvd.com 2004-11-18 06:12:31 EST
I updated rsync to 2.6.3 and everything worked fine. I was able to 
rsync and update the dvd iso file properly. Closing this bug. Thanks 
for your prompt response!

Note You need to log in before you can comment on or make changes to this bug.