Bug 139476 - Compiling on x86-64 fails with "is incompatible with i386:x86-64"-Error
Compiling on x86-64 fails with "is incompatible with i386:x86-64"-Error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 02:15 EST by Stephan Kuhagen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 05:35:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Kuhagen 2004-11-16 02:15:07 EST
Description of problem:
On FC3/x86-64 I can not compile anything (c, c++). I have installed
all compilers as well as the compatibility-libs/devel-packages, which
I think means, that I now have a biarch-compiler-environment. The
default should be 64bit-compiling since this is the primary architecture.

How reproducible:
Fails always.

Steps to Reproduce:
1. This small programm:
----
int main() {
  printf("hallo welt\n");
  return 0;
}
----
fails with
----
/usr/bin/ld: warning: i386 architecture of input file
`/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../crt1.o' is
incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file
`/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../crti.o' is
incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file
`/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../crtn.o' is
incompatible with i386:x86-64 output
/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../crt1.o(.text+0xc): In
function `_start':
: undefined reference to `__libc_csu_fini'
/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../crt1.o(.text+0x11): In
function `_start':
: undefined reference to `__libc_csu_init'
collect2: ld returned 1 exit status
----

Every other programm I tried fails the same way.
Comment 1 Jakub Jelinek 2004-11-16 05:17:17 EST
I'd say you forgot to install glibc-devel.x86_64
Run
rpm -q --qf '%{name}-%{version}-%{release}.%{arch}\n' gcc glibc glibc-headers glibc-devel cpp gcc-c++
and you'll see.


Note You need to log in before you can comment on or make changes to this bug.