Bug 1394861 - Adds OpenDaylight local OVSDB listener
Summary: Adds OpenDaylight local OVSDB listener
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-neutron
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Tim Rozet
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks: 1258832
TreeView+ depends on / blocked
 
Reported: 2016-11-14 15:33 UTC by Itzik Brown
Modified: 2018-10-18 07:21 UTC (History)
5 users (show)

Fixed In Version: puppet-neutron-9.4.2-1.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
N/A
Last Closed: 2016-12-14 16:32:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 394572 None None None 2016-11-14 15:33:23 UTC

Description Itzik Brown 2016-11-14 15:33:23 UTC
Description of problem:
With neutron switching OVSDB configuration to be done via the 'native' library, OVSDB needs to be listening on a port to accept RPCs. This adds a default listener on a non-common port and sets the URI for Neutron when using OpenDaylight so that agents may add ports to OVS.

Version-Release number of selected component (if applicable):
puppet-neutron-9.4.0-2.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tim Rozet 2016-11-21 16:22:50 UTC
Note this gerrit is still outstanding:
https://review.openstack.org/#/c/357528/

This fix will still work, but if OVS is restarted or some interruption occurs, it is possible that neutron dhcp agent will override OVS managers without the above patch.  I have tested this patch on my setup without restarting DHCP agent or OVS and it works.

Comment 3 Jon Schlueter 2016-11-22 16:04:12 UTC
puppet-neutron-9.4.2-1.el7ost contains https://review.openstack.org/394572

Comment 4 Itzik Brown 2016-11-24 14:28:07 UTC
Verified using 
puppet-neutron-9.4.2-1.el7ost.noarch

Comment 6 errata-xmlrpc 2016-12-14 16:32:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.