Bug 139493 - Repeated logging of invalid sleep context with raw1394
Repeated logging of invalid sleep context with raw1394
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 06:10 EST by Mark Cooke
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.12-1.1372_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-19 18:09:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2004-11-16 06:10:41 EST
Description of problem:

When using gnomemeeting with kernel 2.6.9-1.667, repeated logging
occurs, also indicating an error.

Debug: sleeping function called from invalid context at
include/asm/semaphore.h:107
in_atomic():0[expected: 0], irqs_disabled():1
[<0211c8b9>] __might_sleep+0x7d/0x88
[<02244c51>] dma_pool_destroy+0x1a/0x114
[<429b4b6a>] free_dma_rcv_ctx+0x9f/0xc8 [ohci1394]
[<429b2649>] ohci_devctl+0x778/0x799 [ohci1394]
[<42a26657>] hpsb_unlisten_channel+0x3b/0x3e [ieee1394]
[<42da933b>] handle_iso_listen+0x1ab/0x268 [raw1394]
[<42dacc47>] state_connected+0xf1/0x1c7 [raw1394]
[<42dacd9b>] raw1394_write+0x7e/0x92 [raw1394]
[<021656fa>] vfs_write+0xb6/0xe2
[<021657c4>] sys_write+0x3c/0x62


Version-Release number of selected component (if applicable):

Kernel 2.6.9-1.667, i686
gnomemeeting 1.0.2-8_7.rhfc2.at (ATrpms testing)

How reproducible:

100%

Steps to Reproduce:
1.Create the /dev/raw1394 node
2.Connect a firewire camera
3.Start gnomemeeting
4.Preview the local video

Actual results:

Video appears to show okay, but large amounts of logging occurs.
Comment 1 Dave Jones 2005-07-15 13:55:21 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Mark Cooke 2005-07-19 18:09:49 EDT
This update has fixed this problem for me.

Thanks all.

Note You need to log in before you can comment on or make changes to this bug.