Bug 139517 - Hardware detection does not detect the USB ports
Summary: Hardware detection does not detect the USB ports
Status: CLOSED DUPLICATE of bug 137328
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2   
(Show other bugs)
Version: beta
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rob Landry
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-16 15:22 UTC by Gregory Feiner
Modified: 2007-04-18 17:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 12:28:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gregory Feiner 2004-11-16 15:22:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
System: HP DL360 G4
RAM: 1GB
OS: RHEL 4 AS, IA32 & X86_64, Beta 2

Test Kit: rhr2-rhel4-0.9-14.9b.noarch.rpm


Running the test kit seperately.  Not using iSpec.

Problem:  After running hardware dectection, the test kit creates a 
hardware.conf with a incorrect USB setting.  On the DL360 G4, it 
creates a line of "USB 0" even though the system has two USB ports.



Version-Release number of selected component (if applicable):
rhr2-rhel4-0.9-14.9b.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 4 Beta 2
2.  Install the beta test kit
3.  Run pembroke, then run hardware detection.
    

Actual Results:  Incorrect setting in hardware.conf

Expected Results:  Hardware.conf should have a line of "USB 2" for 
this particular server.

Additional info:

Comment 1 Rob Landry 2004-11-18 16:12:05 UTC
It should be prompting the user for the number of USB ports since
because of how USB works it's not actually possible to tell how many
physical ports there are (AFAIK).

Comment 2 Rob Landry 2004-11-18 16:12:30 UTC
Going forward; I think iSpec should establish that value.

Comment 3 Gregory Feiner 2004-11-18 16:16:04 UTC
When running hardware detection, it does not prompt for the number of 
USB ports.

Comment 4 Jay Turner 2004-12-01 09:03:27 UTC
Yeah, it's not prompting under the 2.6 kernel because tests/USB is doing this:

if grep -q usbdevfs /proc/mounts; then

But under 2.6, the usb filesystem gets mounted as "usbfs":

/proc/bus/usb /proc/bus/usb usbfs rw 0 0

Still seeing this with rhr2-rhel4-0.9-14.9e.dummyrun.

Comment 5 Jay Turner 2004-12-01 12:28:01 UTC

*** This bug has been marked as a duplicate of 137328 ***


Note You need to log in before you can comment on or make changes to this bug.