Bug 139551 - FC disk read performance ~50% less than write performance
FC disk read performance ~50% less than write performance
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks: 106771
  Show dependency treegraph
 
Reported: 2004-11-16 12:08 EST by Randy Halverson
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 11:51:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Halverson 2004-11-16 12:08:34 EST
Description of problem:

Comparing the Fibre Channel read/write performance to a direct 
attached JBOD disk, seeing decreased read performance on EL3.0 as 
compared to AS2.1. Seeing the same results if using a QLogic or 
Emulex HBA. So I can only assume that this is a Red Hat issue.

My Results:

AS 2.1
Read    dd if=/FCdisk1/data of=/dev/null bs=100k       40-41MB
Write   dd if=/data of=/FCdisk1/data1 bs=100k           0-15MB

AS 3.0
Read    dd if=/FCdisk1/data of=/dev/null bs=100k       19-20MB
Write   dd if=/data of=/FCdisk1/data1 bs=100k          34-35MB

Notice that the read performance on AS3.0 is about half the write 
performace. I get similar performance results if using Bonnie. I only 
mention that because with the dd command, it only allows or does one 
outstanding request at a time.

Several of our customers have also seen this problem and we direct 
them to Red Hat. 

Can anyone explain why this is occurring and if there are some 
configuration settings, or patch to increase or make the performance 
number more consistent?

Thanks,
Randy

   

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Expected results:

Additional info:
Comment 1 Tom Coughlan 2004-11-17 07:23:14 EST
Which RHEL 3 kernel version are you using?

There are some performance improvements in Update 4.  U4 is in beta
now, and is due out in December. Please re-test with U4.
Comment 2 Randy Halverson 2004-11-29 08:00:32 EST
I'll add Update 4 and retest. I've never done an update before, where 
do I find it since U4 is still in beta?
Comment 3 Tom Coughlan 2004-11-29 09:03:24 EST
Instructions sent by email.
Comment 4 Tom Coughlan 2004-12-03 11:51:08 EST
Randy reports that he can not reproduce this problem on U3:

"I re-installed AS 3.0 on the same system and still not seeing the
read performance issues and I had previously. Getting about the same
read (50MB/sec) and write (54MB/sec) performance."

He has not tried U4. 

Closing this BZ. Reopen if the problem reoccurs.


Note You need to log in before you can comment on or make changes to this bug.