Bug 139563 - RedHat doesn't include "libparted" among the compat libraries.
RedHat doesn't include "libparted" among the compat libraries.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: comps (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: dff
:
Depends On:
Blocks: 137160 146015
  Show dependency treegraph
 
Reported: 2004-11-16 13:22 EST by sheryl sage
Modified: 2007-11-30 17:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-15 23:33:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sheryl sage 2004-11-16 13:22:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Please include 'libparted' comatability library needed for 
IA64.extended systems x86_64

Version-Release number of selected component (if applicable):
libparted comatability library needed for IA64.extended systems x86_64

How reproducible:
Always

Steps to Reproduce:
1.  VERITAS needs this to run 32-bit on 64 bit platforms.  
2.
3.
    

Additional info:
Comment 2 Bill Nottingham 2004-11-17 15:11:29 EST
What specifically does Veritas use libparted for? Note that libparted
is GPL.
Comment 3 Mike McLean 2004-11-17 17:27:35 EST
placing in needinfo.  Note Bill's question in comment#2.
Comment 4 Bob Johnson 2004-12-06 12:21:51 EST
Sheryl, need some answers so we can proceed.
Comment 5 sheryl sage 2004-12-14 15:38:34 EST
We link a 32-bit binary to the shared GPL library, like many others.  
If they don't ship the 32-bit version, though, we can't do that.  
It's no different then our linkage to, say, libc.  For instance, 
vxconfigd:
> 
> [root@vmlx11 vold]# ldd ./vxconfigd
>         libcrypt.so.1 => /lib/libcrypt.so.1 (0x00d8f000)
>         libm.so.6 => /lib/tls/libm.so.6 (0x003b1000)
>         libc.so.6 => /lib/tls/libc.so.6 (0x00288000)
>         libdl.so.2 => /lib/libdl.so.2 (0x003d6000)
>         libvxscsi.so => not found
>         libparted-1.6.so.12 => /usr/lib/libparted-1.6.so.12 
(0xb7f9b000)
>         /lib/ld-linux.so.2 (0x0026b000)
>         libuuid.so.1 => /lib/libuuid.so.1 (0xb7f97000)
> 
Comment 6 Tim Burke 2004-12-20 13:43:11 EST
Is this request RHEL4 specific?  ie, why wasn't this also needed on RHEL3?
Comment 14 Kelvin Pryse 2005-02-03 14:46:31 EST
We didn't use parted in RHEL3, since we weren't supporting EFI/GPT. 
With RHEL4, particularly on ia64, we need to support.  So, we use the
nice libparted interfaces, like any other shared library.  Note we're
not linking to a static library which seems prohibited.  This is just
linking in to a shared library just like the ones in the example
above.  Since our user binaries are all still 32-bit, we'd like the
32-bit libparted included somewhere on both x86_64 and ia64 so we can
use the same binary across all of them. Note that libparted is already
installed on all these archs, but x86_64 and ia64 include only the
64-bit version.
Comment 16 craig harmer 2005-02-15 15:42:21 EST
never mind.  veritas is not going to use libparted.  the fact that
it's licensed GPL rather than LGPL means we can't use it in our
(proprietary) commands.

sorry for the slow followup--it took a little awhile to get everyone
to understand that it was licensed GPL and thus not usable by non-GPL
code.

i would close this bug, but it's apparently blocking a couple of other
bugs that i can't look at so i don't know if they're depending on a fix
or not.
Comment 17 Jeremy Katz 2005-02-15 23:33:22 EST
Closing per last comment.

Note You need to log in before you can comment on or make changes to this bug.