Bug 1395733 - semodule -l no longer returns version information
Summary: semodule -l no longer returns version information
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.2
Hardware: x86_64
OS: Linux
urgent
unspecified
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Milos Malik
Mirek Jahoda
URL:
Whiteboard:
Keywords: Regression, ZStream
Depends On: 1392573
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-16 14:43 UTC by Marcel Kolaja
Modified: 2017-01-17 18:09 UTC (History)
26 users (show)

(edit)
In Red Hat Enterprise Linux 7.3, the semodule tool did not show module versions. Consequently, tools such as Puppet, which expect module version in the output of the "semodule -l" command, stopped working or worked incorrectly. The libsemanage and semodule tools have been fixed to return a module version. If there is no module version available, "(null)" is printed.
Clone Of: 1392573
(edit)
Last Closed: 2017-01-17 18:09:10 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0075 normal SHIPPED_LIVE libsemanage and policycoreutils bug fix update 2017-01-17 22:51:04 UTC
Red Hat Knowledge Base (Solution) 2760071 None None None 2016-11-16 14:43 UTC

Description Marcel Kolaja 2016-11-16 14:43:07 UTC
This bug has been copied from bug #1392573 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 10 errata-xmlrpc 2017-01-17 18:09:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0075.html


Note You need to log in before you can comment on or make changes to this bug.