Bug 1395740 - Overcloud stack with a large number of nodes fails with: Resource CREATE failed: Collection length exceeds 200 elements
Summary: Overcloud stack with a large number of nodes fails with: Resource CREATE fail...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: 10.0 (Newton)
Assignee: Steven Hardy
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-16 14:55 UTC by Marius Cornea
Modified: 2016-12-14 16:33 UTC (History)
7 users (show)

Fixed In Version: instack-undercloud-5.1.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:33:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 398396 None None None 2016-11-16 14:55:46 UTC
Launchpad 1642287 None None None 2016-11-16 15:03:41 UTC

Description Marius Cornea 2016-11-16 14:55:46 UTC
Description of problem:
I'm doing a deployment with 3 controllers and 40 compute nodes and the overcloud stack creation fails with:

Resource CREATE failed: Collection length exceeds 200 elements

Version-Release number of selected component (if applicable):
instack-undercloud-5.0.0-4.el7ost.noarch

It looks that we need to increase the [yaql] limit_iterators in /etc/heat/heat.conf as with the current version the default value gets set.

Comment 1 Steven Hardy 2016-11-16 15:02:26 UTC
The problem is we're missing a fix that increases the yaql limit_iterators in the heat.conf on the undercloud (from the default of 200, which is too small for the large stacks we're creating with TripleO in this case).

Upstream bug raised, and backport proposed:

https://bugs.launchpad.net/tripleo/+bug/1642287

https://review.openstack.org/#/c/398396/

Comment 2 Marius Cornea 2016-11-16 15:08:46 UTC
Workaround:

1. Create hieradata file:

cat /home/stack/custom_hiera.yaml 
heat::yaql_limit_iterators: 1000

2. Edit undercloud.conf and point it to the hieradata file
hieradata_override =  /home/stack/custom_hiera.yaml

3. Rerun openstack undercloud install

Comment 3 Steven Hardy 2016-11-25 11:22:06 UTC
https://review.openstack.org/#/c/398396/ landed, verfied by inspection it's included in instack-undercloud-5.1.0-3.el7ost.noarch.rpm

Comment 6 errata-xmlrpc 2016-12-14 16:33:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.