Bug 1395791 - ValueError: Namespace BlockDev not available for version 1.0 (blivet explicitly requires libblockdev 1.0, but it's now 2.0; crashes anaconda)
Summary: ValueError: Namespace BlockDev not available for version 1.0 (blivet explicit...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F26AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-11-16 16:41 UTC by Adam Williamson
Modified: 2016-12-09 19:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-09 19:16:39 UTC


Attachments (Terms of Use)

Description Adam Williamson 2016-11-16 16:41:49 UTC
openQA installer tests of today's Rawhide nightly - Fedora-Rawhide-20161116.n.0 - all crashed with:

ValueError: Namespace BlockDev not available for version 1.0

in a traceback that points to:

gi.require_version("BlockDev", "1.0")

in blivet/util.py . See e.g. https://openqa.fedoraproject.org/tests/48712#step/_boot_to_anaconda/8 .

This is an automatic F26 Alpha blocker as it prevents all installer images from booting to anything useful.

Comment 1 Vratislav Podzimek 2016-11-18 07:43:56 UTC
https://github.com/rhinstaller/blivet/pull/525

Sorry about this, I somehow expected the useless calls that just prevent stupid warnings being printed to stderr would just consider 2.0 a higher version than 1.0 and move on. Blivet works with both BlockDev-1.0 and BlockDev-2.0, but that's impossible to tell to that stupid function unless we add more useless code trying to call it twice.

Comment 2 Adam Williamson 2016-12-09 19:16:39 UTC
This is OK now, install tests are mostly working.


Note You need to log in before you can comment on or make changes to this bug.