Bug 1395818 - rpm does not verify %ghost files
Summary: rpm does not verify %ghost files
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Jan Blazek
Marie Dolezelova
URL:
Whiteboard:
Keywords:
: 1568628 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-16 18:26 UTC by Jan Pokorný [poki]
Modified: 2018-10-30 11:34 UTC (History)
5 users (show)

Fixed In Version: rpm-4.11.3-34.el7
Doc Type: Release Note
Doc Text:
The "--noghost" option has been added to the "rpm -V" command This update adds the "--noghost" option to the "rpm -V" command. If used with this option, "rpm -V" verifies only the non-ghost files that were altered, which helps diagnose system problems.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 11:34:10 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3250 None None None 2018-10-30 11:34 UTC
Red Hat Bugzilla 1584313 None CLOSED grubby rpm mode inconsistency on /etc/sysconfig/kernel 2019-03-11 08:43 UTC

Internal Trackers: 1584313

Description Jan Pokorný [poki] 2016-11-16 18:26:43 UTC
# yum install pcs; systemctl start pcsd; systemctl stop pcsd
> [...]

# rpm -q pcs
> pcs-0.9.152-10.el7.x86_64

# rpm -qlvv pcs | grep cookiesecret
> ----------    1 root    root                        0 Sep 20 11:25 /var/lib/pcsd/pcsd.cookiesecret

# rpm -Vvv pcs |& grep cookiesecre
> [nothing]

# chgrp haclient /var/lib/pcsd/pcsd.cookiesecret

# rpm -Vvv pcs |& grep cookiesecre
> [nothing]


One would expect that all metadata except for checksum+size are tracked
and checked usual.  Desired state is that the last command will indicate
the group ownership of the file differs from a predestined one.


# rpm -q rpm
> rpm-4.11.3-21.el7.x86_64

Comment 1 Panu Matilainen 2016-11-17 07:44:35 UTC
Confirmed, this broken upstream too, probably been that way for ages/ever.

Comment 4 Jan Pokorný [poki] 2016-11-18 09:40:23 UTC
Thanks; it's important to get there, regardless time-to-notice :-)

Comment 5 Panu Matilainen 2018-01-12 11:41:47 UTC
Lest it be forgotten, if/when the patch from comment #2 is applied, this is needs to go with it to avoid other regressions: https://github.com/rpm-software-management/rpm/commit/7013a82d575309be8b7a382fcb5aa57a9f4e4635

Comment 6 Panu Matilainen 2018-04-06 08:42:04 UTC
Another fix this will need is the POPT_BIT_CLR -> POPT_BIT_SET change from https://github.com/rpm-software-management/rpm/commit/efd696d32d343b82832dd9e4aee992bff8e64ad0 - and why not documentation as well.

Comment 8 Pavlina Moravcova Varekova 2018-06-20 08:52:46 UTC
*** Bug 1568628 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2018-10-30 11:34:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3250


Note You need to log in before you can comment on or make changes to this bug.