Bug 139590 - Sound settings not saved during shutdown
Sound settings not saved during shutdown
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 15:39 EST by Hesty
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 09:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/asound.state (7.03 KB, text/plain)
2004-11-21 16:47 EST, Hesty
no flags Details
/etc/init.d/halt (5.89 KB, text/plain)
2004-11-21 16:48 EST, Hesty
no flags Details

  None (edit)
Description Hesty 2004-11-16 15:39:51 EST
Description of problem:
Sound settings are not save during shutdown. FC3 always start with
sound muted or 0 volume.

Version-Release number of selected component (if applicable):
FC3

How reproducible:
Always

Steps to Reproduce:
1. Enable sound, set the volume to your liking.
2. Shutdown and restart.
3. 
  
Actual results:
Sound settings back to 0 volume.

Expected results:
Sound settings is saved.

Additional info:
In old OSS days, a couple of lines in /etc/modules.conf do the job of
conserving the sound settings. Can the same be used in
/etc/modproble.conf?
Comment 1 Bill Nottingham 2004-11-17 01:36:00 EST
There already is code in /etc/init.d/halt.

What does your /etc/asound.state look like?
Comment 2 Hesty 2004-11-21 16:47:34 EST
Created attachment 107145 [details]
/etc/asound.state
Comment 3 Hesty 2004-11-21 16:48:01 EST
Created attachment 107146 [details]
/etc/init.d/halt
Comment 4 Bill Nottingham 2004-11-21 23:49:40 EST
You've got valid settings in your /etc/asound.state - what happens if
you run 'alsactl restore'?
Comment 5 Hesty 2004-11-22 01:47:14 EST
I can only run alsactl restore as root. When I do that, nothing
changes with my volume settings.
Comment 6 Bill Nottingham 2004-11-22 02:25:45 EST
Odd... looking at your saved state, there certainly are some that are
non-zero... everything is still muted in alsamixer? Or can you just
not hear anything?
Comment 7 Hesty 2004-11-25 10:54:40 EST
alsactl restore does not mute or set volume to zero at all. Only
reboot sets the volume to zero. When that happens, I have to use
either alsamixer or aumix to reset my volumes. Is it possible that the
saved state somehow got wiped out during shutdown?
Comment 8 Bill Nottingham 2004-11-26 01:10:58 EST
The volume always defaults to zero... 'alsactl restore' should work to
restore the settings for you ; does that not work instead of
alsamixer/etc?
Comment 9 Hesty 2004-11-26 01:12:46 EST
Oh, I understand what you mean now. I'll try that the next time I
restart. If that works, do I just add 'alsactl restore' to one of the
init script?
Comment 10 Bill Nottingham 2004-11-28 15:13:33 EST
No, alsactl should be run automatically when the module is loaded.
Comment 11 Martin Stransky 2005-01-03 05:43:08 EST
Do you work with any window managers (KDE/GNOME), or only on text
console? Because window managers realy set volume control to zero
during login (especially KDE).
Comment 12 Hesty 2005-01-06 16:13:36 EST
I use GNOME most of the time, but I have tried shutdown and logging
into KDE (through gdm) with the same result.
Comment 13 Martin Stransky 2005-01-07 03:46:51 EST
It might be problem of GNOME/KDE. If you use only console (not any X,
you have to modify first line of /etc/inittab, you could use
"id:3:initdefault:"), work save/restore properly? If you use alsamixer
to set volume and reboot, is volume ok (on text console)? 
Comment 14 Hesty 2005-02-03 16:54:09 EST
Alright, here is the breakthrough that's needed:
When I issue the command:
> alsactl store 0
Segmentation fault.

There is also an error during shutdown when saving mixer settings.
Segmentation fault is also the error message. Any idea what's the problem?
Comment 15 Martin Stransky 2005-02-11 05:22:11 EST
Could you please try new version from devel (1.0.8)?
Comment 16 Hesty 2005-02-16 04:19:59 EST
Did you mean alsa-utils or alsa-lib? I tried alsa-utils since alsactl
is in alsa-utils, but I got this error message:
# alsactl store 0
alsactl: relocation error: alsactl: symbol snd_ctl_elem_info_is_user,
version ALSA_0.9 not definedin file libasound.so.2 with link time
reference

Done with:
alsa-utils-1.0.8-1
alsa-lib-1.0.6-7.FC3
Comment 17 Martin Stransky 2005-02-16 04:25:29 EST
I thought new kernel, alsa-lib and alsa-utils from devel.
Comment 18 Martin Stransky 2005-04-15 04:39:23 EDT
Any news?
Comment 19 Hesty 2005-04-29 13:39:02 EDT
Problem goes away when I added the mixer applet to gnome, however, issuing the
command:

[root@localhost ~]# alsactl store 0
alsactl: relocation error: alsactl: symbol snd_ctl_elem_info_is_user, version
ALSA_0.9 not defined in file libasound.so.2 with link time reference

still gives this error and this error still appears during shutdown. However, it
seems like the mixer applet saves its own settings and reload it everytime
during startup.
Comment 20 Hesty 2005-04-29 13:46:52 EDT
Nevermind, problem fixed when using:
alsa-lib-1.0.9rc2-1
alsa-utils-1.0.9rc2-1

Note You need to log in before you can comment on or make changes to this bug.