Bug 139591 - httpd-2.0.52-3.1: when browsing directories, large files are not listed
Summary: httpd-2.0.52-3.1: when browsing directories, large files are not listed
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-16 20:51 UTC by Andres Lippur
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 22:06:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andres Lippur 2004-11-16 20:51:23 UTC
Description of problem:
When browsing directories, large files (>2GB) not displayed in
directory listings, probably mod_autoindex problem.

Version-Release number of selected component (if applicable):
httpd-2.0.52-3.1

How reproducible:
Always

Steps to Reproduce:
1. copy large files to server
2. browse large files via http
3. you know these files are there, but you can't see them
  
Actual results:
large files are gone

Expected results:
expected see all files

Additional info:
for example you can test here (running httpd-2.0.52-3.1):

http://ftp.siiludus.com/pub/fedora/linux/core/3/iso/heidelberg-i386-DVD/
ftp://ftp.siiludus.com/pub/fedora/linux/core/3/iso/heidelberg-i386-DVD/

Comment 1 Joe Orton 2004-11-16 22:06:10 UTC
Thanks for the report.  This is fixed for httpd 2.1 and later but
can't be backported to httpd 2.0 because it breaks the binary module
interface, unfortunately.  The best recommendation in the meantime is
to set up redirects to the FTP site for the DVD ISOs.


Note You need to log in before you can comment on or make changes to this bug.