Bug 139594 - usb sync of a palm of a palm pilot causes a destructive crash
usb sync of a palm of a palm pilot causes a destructive crash
Status: CLOSED DUPLICATE of bug 140125
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
http://dcs.nac.uci.edu/~strombrg/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 16:03 EST by Dan Stromberg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages which hopefully contains info about my palm+usb sync crashes (766.39 KB, text/plain)
2004-11-17 15:04 EST, Dan Stromberg
no flags Details

  None (edit)
Description Dan Stromberg 2004-11-16 16:03:52 EST
Description of problem:
When I try to sync (sometimes) or back up (always) my PalmOne Tungsten
C (with the English version of TC Update 3) over USB, my system
crashes.  The mouse won't move, and I cannot ping the machine.  Only
my work machine has this problem.  My home machine is fine.

Version-Release number of selected component (if applicable):
Both jpilot and pilot-xfer lead to crashes.  I tried with and without
"yum -y update", and both give crashes.

How reproducible:
Sync: Crashes sometimes
Backup: Crashes every time

Steps to Reproduce:
1. Hook up a PalmOne Tungsten C to a USB cable
2. Attempt to back up the palm over USB using jpilot or pilot-xfer
3. System crashes hard
  
Actual results:
As I've said, the machine crashes.  What I haven't said yet is, that
about 1 time in 3, the system's swap gets messed up, rendering the
machine unbootable.  I've had a little success so far with booting
single user, and then re-mkswap'ing my swap partitions.  After that,
I've been able to boot again.

Expected results:
What's intended is for copies of almost all of the files on the palm
pilot to be transferred to my desktop FC3 system, to allow them to be
edited on the desktop and/or restored to the palm in the event of a
palm pilot hard crash.

Additional info:
My work machine, the one that's crashing, has:

00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 1a) (prog-if 00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at d400 [size=32]
        Capabilities: [80] Power Management version 2

00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 1a) (prog-if 00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at d800 [size=32]
        Capabilities: [80] Power Management version 2


My home machine, the one that mostly works (on this machine, I just
have to unload and reload some modules sometimes - OK, often), has:

00:01.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07) (prog-if 10 [OHCI])
        Subsystem: Silicon Integrated Systems [SiS] USB 1.0 Controller
        Flags: bus master, medium devsel, latency 64, IRQ 3
        Memory at cfffc000 (32-bit, non-prefetchable) [size=4K]

00:01.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07) (prog-if 10 [OHCI])
        Subsystem: Silicon Integrated Systems [SiS] Onboard USB Controller
        Flags: bus master, medium devsel, latency 64, IRQ 3
        Memory at cfffd000 (32-bit, non-prefetchable) [size=4K]


Please let me know if there's something I can tweak or patch to be rid
of this problem.  I'd be willing to test beta code.  This is a really
serious problem for me, since I rely heavily on my desktop system at
work to sync with my Palm Pilot.

Thanks!
Comment 1 Dan Stromberg 2004-11-16 16:52:59 EST
I probably should add that the same system that has problems with FC3,
worked pretty well for USB sync'ing the same palmone Tungsten C, with
the same Update3_En, and the same USB cable.

Thanks!
Comment 2 Dan Stromberg 2004-11-16 19:24:54 EST
Urgh, that was a bit incoherent.  Let me try that again.  :)

I probably should add that the same system that has problems with FC3,
worked pretty well for USB sync'ing the same palmone Tungsten C, with
the same Update3_En, and the same USB cable back when I had Fedora
Core 2 on it.

Comment 3 Ngo Than 2004-11-17 11:28:23 EST
you mean with the same hardware it works fine with FC2, but crash with
FC3?

it looks like a kernel problem here. could you please send the
/var/log/messages file. Thanks

Comment 4 Dan Stromberg 2004-11-17 15:04:18 EST
Created attachment 106906 [details]
/var/log/messages which hopefully contains info about my palm+usb sync crashes

I hope this attachment isn't too big.

I've attempted to get most of the relevant stuff.  I haven't clipped out
anything between the times in the first and last lines.

Thanks!
Comment 5 Dan Stromberg 2004-11-17 17:30:08 EST
Yes, the same system, same cradle, same palm pilot, same firmware on
the palm pilot: worked pretty well with FC2, under FC3 instead crashes
consistently when backing up the palm, crashes sometimes when sync'ing
the palm, and about 1 time in 3 on a crash, something bad happens to
a/the swap partition(s).

Thanks!
Comment 6 Ngo Than 2004-11-18 06:27:48 EST
i don't see any info about the crash in log file. Do you see any crash
info on your console if you try pilot-xfer in console (without X)?
Comment 7 Dan Stromberg 2004-11-18 15:21:09 EST
Does this stuff look relevant?

Nov 16 08:39:07 tesuji kernel: recvmsg bug: copied 5EB8A3E0 seq
5EB8A981284)
Nov 16 08:39:07 tesuji kernel: recvmsg bug: copied 5EB8A3E0 seq 5EB8A988
Nov 16 08:39:07 tesuji kernel: KERNEL: assertion (tp->copied_seq ==
tp->rcv_nxt || (flags & (MSG_PEEK | MSG_TRUNC))) failed at
net/ipv4/tcp.c (1348)
Nov 16 08:39:07 tesuji kernel: KERNEL: assertion (flags & MSG_PEEK)
failed at net/ipv4/tcp.c (1284)
Nov 16 08:39:07 tesuji kernel: recvmsg bug: copied 5EB8A3E0 seq 5EB8A988
Nov 16 08:39:07 tesuji kernel: KERNEL: assertion (tp->copied_seq ==
tp->rcv_nxt || (flags & (MSG_PEEK | MSG_TRUNC))) failed at
net/ipv4/tcp.c (1348)
Nov 16 08:39:07 tesuji kernel: KERNEL: assertion (flags & MSG_PEEK)
failed at net/ipv4/tcp.c (1284)
Nov 16 08:39:07 tesuji kernel: recvmsg bug: copied 5EB8A3E0 seq 5EB8A988
Nov 16 08:39:07 tesuji kernel: KERNEL: assertion (tp->copied_seq ==
tp->rcv_nxt || (flags & (MSG_PEEK | MSG_TRUNC))) failed at
net/ipv4/tcp.c (1348)
Nov 16 08:39:07 tesuji kernel: KERNEL: assertion (flags & MSG_PEEK)
failed at net/ipv4/tcp.c (1284)
Nov 16 08:39:07 tesuji kernel: recvmsg bug: copied 5EB8A3E0 seq 5EB8A988
Comment 8 Dan Stromberg 2004-11-18 15:43:44 EST
I ran:

pilot-xfer -p /etc/udev/devices/ttyUSB1 -b .

And a while later, I got a panic message, which ended with:

pilot-xfer ...
...
Call trace:
... Schedule_timeout
... Process_timeout
... do_select
... __pollwait
... get_user_size
... sys_select

...this is of course, greatly abbreviated.  Please let me know if you
need more detail, like the addresses involved or whatever.

Thanks!
Comment 9 Ngo Than 2004-11-19 05:34:07 EST
Dan, could you please attach the complete panic messages? thanks
Comment 10 Ngo Than 2004-11-22 04:41:17 EST
it looks like a bug in kernel. i assign it to correct component. Many
thanks for your infos

*** This bug has been marked as a duplicate of 140125 ***
Comment 11 Red Hat Bugzilla 2006-02-21 14:07:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.