Bug 139596 - accidental libxml2 shared library hijack causes multiple errors
accidental libxml2 shared library hijack causes multiple errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 16:14 EST by Roger E Critchlow Jr
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 19:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger E Critchlow Jr 2004-11-16 16:14:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Upgrading redhat 9.0 to fc3 I discovered that my install of ActiveTcl
had a version of libxml2 which hijacked all references away from the
version installed by fc3.  This resulted in mysterious component
failures too numerous to list.  The most explicit was that yum would
fail with a missing symbol when loading the python interface to
libxml2, hence I had to perform all updates manually.  The most
obvious was that Gnome session startup would end with errors, and many
aspects of the Gnome desktop were broken or flakey.  After upgrading
the libxml2 and python interfaces, I finally ran ldd on the python
interface library and solved the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install ActiveState ActiveTcl 8.4.6.0 Mar 01, 2004 (Build 93230)
into /usr/local/ActiveTcl.
2. Add /usr/local/ActiveTcl/lib to /etc/ld.so.conf and run ldconfig.
3. Watch most of fc3's xml processing fail
    

Actual Results:  Nothing, until you use something which uses libxml2,
then all sorts of processes begin to fail because the ActiveTcl
libxml2 doesn't provide the same API as the version installed with fc3.

Expected Results:  Either the installation process or the system
startup should detect that a very crucial shared library dependency
has been broken and needs to be fixed before fc3 will work as designed.

Additional info:
Comment 1 Daniel Veillard 2004-11-16 19:53:40 EST
Seems ActiveTcl is not properly configured for fedora core 3. I
suggest you report this directly to them. It is not a package 
we maintain.

Daniel

Note You need to log in before you can comment on or make changes to this bug.