Bug 1396073 - [RFE] Add identifier for Slave logs
Summary: [RFE] Add identifier for Slave logs
Keywords:
Status: CLOSED DUPLICATE of bug 1412689
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-17 12:11 UTC by Aravinda VK
Modified: 2017-01-13 04:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 04:49:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-11-17 12:11:05 UTC
Description of problem:
All slave logs from different workers are logged in one log file. This makes it very difficult to debug.

Maintain the session dir in /var/log/glusterfs/geo-replication-slaves/

For example:
Existing:
/var/log/glusterfs/geo-replication-slaves/<master_vol_uuid>:<name>.log

Proposed:
/var/log/glusterfs/geo-replication-slaves/<session or master uuid>/<master_brick>:<name>.log

Comment 1 Aravinda VK 2017-01-13 04:49:56 UTC

*** This bug has been marked as a duplicate of bug 1412689 ***


Note You need to log in before you can comment on or make changes to this bug.