Bug 1396197 - Backport: mod_proxy_wstunnel - AH02447: err/hup on backconn
Summary: Backport: mod_proxy_wstunnel - AH02447: err/hup on backconn
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik
QA Contact: David Jež
URL:
Whiteboard:
Keywords: Patch, ZStream
Depends On:
Blocks: 1298243 1429606 1429947
TreeView+ depends on / blocked
 
Reported: 2016-11-17 17:34 UTC by Robert Bost
Modified: 2017-08-01 21:36 UTC (History)
9 users (show)

(edit)
Previously, httpd running in a container returned the 500 HTTP status code (Internal Server Error) when a connection to a WebSocket server was closed. As a consequence, the httpd server failed to deliver the correct HTTP status and data to a client. With this update, httpd correctly handles all proxied requests to the WebSocket server, and the described problem no longer occurs.
Clone Of:
: 1429606 1429947 (view as bug list)
(edit)
Last Closed: 2017-08-01 21:36:44 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2175 normal SHIPPED_LIVE httpd bug fix update 2017-08-01 18:40:47 UTC

Description Robert Bost 2016-11-17 17:34:29 UTC
Description of problem: Need backport of upstream fix for mod_proxy_wstunnel bug:

  https://bz.apache.org/bugzilla/show_bug.cgi?id=56299


Version-Release number of selected component (if applicable): httpd-2.4.6-40


How reproducible: Always


Steps to Reproduce:
Requires httpd docker container and can use https://github.com/dpallot/simple-websocket-server.git in another container.

Customer unable to reproduce with plain httpd on RHEL. Docker is required.

Actual results: Websockets requests end with 500 status, even after data.


Expected results: No 500 status


Additional info:

Comment 15 errata-xmlrpc 2017-08-01 21:36:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2175


Note You need to log in before you can comment on or make changes to this bug.