Bug 1396377 - kdump is not working with MRG-RT kernel when using EFI
Summary: kdump is not working with MRG-RT kernel when using EFI
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools
Version: 6.9
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Dave Young
QA Contact: Emma Wu
URL:
Whiteboard:
Keywords: OtherQA
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-18 08:42 UTC by Daniel Bristot de Oliveira
Modified: 2018-05-18 05:23 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-03-21 09:12:54 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0584 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2017-03-21 12:24:25 UTC

Description Daniel Bristot de Oliveira 2016-11-18 08:42:30 UTC
Description of problem:
When running the kernel-rt-3.10.0-xxx (provided by MRG-RT product) on an RHEL6 in a system with EFI, the kdump does not work.

When the user hits sysrq + c, the system hangs without sending any information to the serial console.

Version-Release number of selected component (if applicable):
kernel-rt-3.10.0-229.rt56.147.el6rt.x86_64
kexec-tools-2.0.0-280.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot the system with efi enabled
2. Try to crash the system
3. System hangs

Actual results:
System hangs

Expected results:
kdump created

Additional info:
Workarounds:

There are two workarounds for the problem.

The first is to boot the system disabling EFI using the noefi kernel parameter.

The second is to umount debugfs before starting kdump service.

Comment 6 Dave Young 2016-11-21 05:07:42 UTC
Daniel

Can you answer the question from QE why using 3.10 kernel with RHEL6 userspace? and Why not use RHEL7 user space?

Comment 10 Daniel Bristot de Oliveira 2016-11-22 08:34:18 UTC
Hi Qiao,

The customer that faced the bug did the major part of the debugging. As they are very advanced users, I am quite sure they are open to test a solution if we deliver them a test package. Is that enough - the customer testing the solution?

-- Daniel

Comment 11 Qiao Zhao 2016-11-22 08:54:05 UTC
(In reply to Daniel Bristot de Oliveira from comment #10)
> Hi Qiao,
> 
> The customer that faced the bug did the major part of the debugging. As they
> are very advanced users, I am quite sure they are open to test a solution if
> we deliver them a test package. Is that enough - the customer testing the
> solution?
> 
> -- Daniel

Yes, It's ok for me. Thank you very much!

Set qa_ack+ and add OtherQA keywords.

Comment 12 Dave Young 2016-11-23 06:41:02 UTC
Here is a test build, I have tested on local machine, but feel free to do a test:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=12139772

Comment 13 Dave Young 2016-11-23 08:59:11 UTC
Hi, This is the V2 build though I believe there are no difference for testing:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=12140195

Comment 14 Daniel Bristot de Oliveira 2016-11-23 13:24:41 UTC
Hi!

Test package delivered to the customer. Now waiting on customer's feedback.

Thanks!

Comment 15 Daniel Bristot de Oliveira 2016-11-28 08:04:16 UTC
Hi!

The customer tested the package and said that it fixed the problem.

Is there an ETA for the GA of this fix?

Thank you very much for the agility in this case.

-- Daniel

Comment 16 Dave Young 2016-11-29 05:31:21 UTC
Hi,

Once the patch being reviewed in kdump mail list, we can merge it and create a official build, hopefully it will be within one week or two. But the GA for customer depends on RHEL6.9 schedule..

Thanks
Dave

Comment 24 errata-xmlrpc 2017-03-21 09:12:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0584.html


Note You need to log in before you can comment on or make changes to this bug.