Bug 1396386 - glib2-fam prints an extra string and breaks gnome-ssh-askpass
Summary: glib2-fam prints an extra string and breaks gnome-ssh-askpass
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glib2
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-18 08:54 UTC by bugreports2005
Modified: 2017-08-01 12:28 UTC (History)
4 users (show)

Fixed In Version: glib2-2.50.3-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 12:28:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
A trivial patch that stops printing the string (422 bytes, patch)
2016-11-18 08:54 UTC, bugreports2005
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2100 normal SHIPPED_LIVE GTK+ bug fix update 2017-08-01 16:06:50 UTC

Description bugreports2005 2016-11-18 08:54:47 UTC
Created attachment 1221781 [details]
A trivial patch that stops printing the string

Description of problem:

I think starting from RHEL7.3, gnome-ssh-askpass no longer work correctly if glib2-fam is installed and the Oxygen-gtk theme is in use. This turns out to be because /usr/lib64/gio/modules/libgiofam.so prints a debug string that is then prepended to the password, breaking it.

Other software are also affected.


Version-Release number of selected component (if applicable):

glib2-2.46.2-4.el7.x86_64


How reproducible:

Reproducible.

Steps to Reproduce:
1. yum install glib2-fam openssh-askpass
2. select Oxygen-gtk as the GTK+ theme from from tweak-tool
3. run /usr/libexec/openssh/gnome-ssh-askpass

Actual results:

The prompt for password opens and "II 1" already gets written to stdout.


Expected results:

Nothing is written to stdout until something is entered into the password prompt - then only the password is, nothing else.


Additional info:

The same bug about a year ago with pinentry-gtk-2 in OpenSUSE:
https://bugzilla.novell.com/show_bug.cgi?id=951221

Comment 2 Dimitrios Gerasimatos 2017-03-15 20:27:52 UTC
This bug is actually quite a critical bug in that the output is produced in many situations. We were unable to deploy the latest OS updates (because this bug introduced output when our s/w was invoked) until we finally discovered the cause of this bug (after many man hours of trying to replicate and understand it), found this bugzilla, and recompiled glib2 with the included patch. 

It is a trivial fix. The patch included here fixes it according to our testing. Please ship ASAP, because recompiling glib2 each time there is an update is tedious and introduces risk.

Comment 3 Colin Walters 2017-03-16 13:15:20 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=780144

Comment 7 errata-xmlrpc 2017-08-01 12:28:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2100


Note You need to log in before you can comment on or make changes to this bug.