Bug 139650 - net ads join segfaults
Summary: net ads join segfaults
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 07:30 UTC by Thomas M Steenholdt
Modified: 2014-08-31 23:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 02:34:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas M Steenholdt 2004-11-17 07:30:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040916

Description of problem:
Problem occurs when trying to add an FC3 x86_64 samba machine to an
ADS domain. the "net ads join" command will segfault.

(both the version included in FC3 and the development version
(3.0.8-3) have this problem)

Problem is known and resolved in samba:

https://bugzilla.samba.org/show_bug.cgi?id=2036

Please include fix here.

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup system to prepare to join ADS domain
2. run net ads join -U administrator@DOMAIN.COM
3. sigh as the command segfaults ;-/
    

Actual Results:  Segfault

Expected Results:  No segfault

Additional info:

Comment 1 Nerijus Baliūnas 2005-04-14 22:58:21 UTC
Seems to be fixed in samba-3.0.10-1.fc3, so this bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.