Bug 139661 - pdflatex crashes when including PNG image
pdflatex crashes when including PNG image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 04:56 EST by Ben Liblit
Modified: 2013-07-02 19:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 05:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PNG file for inclusion into document (1.32 KB, image/png)
2004-11-17 04:57 EST, Ben Liblit
no flags Details
LaTeX document to be rendered using "pdflatex master" (112 bytes, text/plain)
2004-11-17 04:58 EST, Ben Liblit
no flags Details

  None (edit)
Description Ben Liblit 2004-11-17 04:56:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
I have a specific PNG image file which consistently crashes pdflatex.
 When I pull that image into a document using "\includegraphics",
pdflatex gets a segmentation fault.

The PNG image appears to be well-formed.  This all worked fine under
Fedora Core 2, so apparently this is a regression under Fedora Core 3.

I will attach the image and an example LaTeX document to this report.

Version-Release number of selected component (if applicable):
tetex-latex-2.0.2-21

How reproducible:
Always

Steps to Reproduce:
1. Save "master.tex" and "status-enabled.png", which are attached to
this report.
2. Run "pdflatex master".

Actual Results:  pdflatex crashes with a segmentation fault at the
point where it tries to pull in the PNG image.

Expected Results:  pdflatex should have completed without error,
yielding a PDF document showing the PNG image.

Additional info:
Comment 1 Ben Liblit 2004-11-17 04:57:57 EST
Created attachment 106883 [details]
PNG file for inclusion into document
Comment 2 Ben Liblit 2004-11-17 04:58:40 EST
Created attachment 106884 [details]
LaTeX document to be rendered using "pdflatex master"
Comment 3 Jindrich Novy 2004-11-18 04:02:25 EST
Hi Ben,

yes, I see the bug. The problem is with import of PNG images with
alpha channel. I tried to cut out the alpha channel and I no longer
face the segfault problem. So you can use it as a simple workaround now.

I'm now figuring out the reason for the segfault.

thanks,
Jindrich
Comment 4 Ben Liblit 2004-11-18 04:20:43 EST
Jindrich, thank you so much for taking the time to look at this.  I
worried it wouldn't get much attention since pdflatex is a bit obscure.

pdflatex doesn't do anything useful with alpha channels anyway, at
least not yet.  The workaround you suggest will be easy to enact and
will get me back up and running (or at least typesetting) quickly.

Thanks again!
Comment 5 Jindrich Novy 2004-12-02 05:54:27 EST
Ben, I found the reason why pdflatex segfaults. It looks like the
problem is not in pdflatex but libpng. The pdflatex segfaults only
with libpng-1.2.7. To fix this please downgrade to libpng-1.2.2, where
this error doesn't occur. (tested)

You can get working libpng from:
http://sunsite.mff.cuni.cz/pub/fedora/2/i386/os/Fedora/RPMS/libpng-1.2.2-22.i386.rpm


I'll file a bug against libpng so hopefully this will be solved soon.

greetings,
Jindrich
Comment 6 Jindrich Novy 2004-12-07 05:25:24 EST
The new release of libpng-1.2.8 fixes the issue.
Comment 7 Ben Liblit 2004-12-13 21:20:40 EST
Fix confirmed in libpng-1.2.8-1.fc3.

Thanks, Jindrich!

Note You need to log in before you can comment on or make changes to this bug.