Bug 139664 - Sysctl error messages from /etc/init.d/network when using IPv6
Sysctl error messages from /etc/init.d/network when using IPv6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 05:33 EST by Troels Arvin
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 17:08:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My sysctl.conf (634 bytes, text/plain)
2004-11-17 16:13 EST, Troels Arvin
no flags Details

  None (edit)
Description Troels Arvin 2004-11-17 05:33:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When booting/shutting down/changing runlevel, I get this error message:
error: unknown error 22 reading key 'net.ipv6.route.flush'
error: unknown error 22 reading key 'net.ipv4.route.flush'
error: unknown error 22 reading key 'fs.binfmt_misc.register'

The same error messages appear if I do
sysctl -a >/dev/null

I don't know if the error messages really indicate something bad. But
the messages are not "pretty" during boot/shutdown.

I've narrowed the problem down to the /etc/init.d/network script and
the related /etc/sysconfig/networking file. If I put the following
line into /etc/sysconfig/networking, the problem exists:
NETWORKING_IPV6=yes

If the above value is set to "no", then the problem goes away (as well
as my IPv6 connectivity...).

I've tried going through the contents of the initscript package,
trying to find instances of "sysctl -a", changing them to "sysctl -e
-a", for a start. But that didn't help, or I missed something.

Apart from that, I'm wondering if the sysctl error messages is
something that I should worry about.

Version-Release number of selected component (if applicable):
initscripts-7.93.5-1

How reproducible:
Always

Steps to Reproduce:
1. Set NETWORKING_IPV6 to "yes" in /etc/sysconfig/network
2. "Run /etc/init.d/network restart"


Actual Results:  Shutting down interface eth1:                       
      [  OK  ]
Shutting down interface sit2:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
error: unknown error 22 reading key 'net.ipv6.route.flush'
error: unknown error 22 reading key 'net.ipv4.route.flush'
error: unknown error 22 reading key 'fs.binfmt_misc.register'
error: unknown error 22 reading key 'net.ipv6.route.flush'
error: unknown error 22 reading key 'net.ipv4.route.flush'
error: unknown error 22 reading key 'fs.binfmt_misc.register'
Setting network parameters:                                [  OK  ]
Bringing up loopback interface:                            [  OK  ]

Expected Results:  Shutting down interface eth1:                     
        [  OK  ]
Shutting down interface sit2:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Setting network parameters:                                [  OK  ]
Bringing up loopback interface:                            [  OK  ]

Additional info:
Comment 1 Bill Nottingham 2004-11-17 16:02:54 EST
Can you attach your /etc/sysctl.conf?
Comment 2 Troels Arvin 2004-11-17 16:13:05 EST
Created attachment 106912 [details]
My sysctl.conf

As requested: My /etc/sysctl.conf. Should be as distributed, except for
kernel.sysrq = 1
and
dev.rtc.max-user-freq = 1024
Comment 3 Bill Nottingham 2004-11-17 16:35:08 EST
The kernel is returning -EINVAL.
Comment 4 Paul 2004-11-29 22:53:44 EST
I recently upgraded from RH9, with IPv6 enabled, and I am seeing the
same problem.
Comment 5 Dave Jones 2005-07-15 14:33:26 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Troels Arvin 2005-07-16 17:06:53 EDT
With kernel 2.6.12-1.1372_FC3, I don't get error messages any more. Thanks.

Note You need to log in before you can comment on or make changes to this bug.