This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 139672 - pasting text from a FC2 machine into an FC3 window kills the FC2 window
pasting text from a FC2 machine into an FC3 window kills the FC2 window
Status: CLOSED DUPLICATE of bug 139846
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 07:20 EST by Don Caldwell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Caldwell 2004-11-17 07:20:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
when i try to cut and paste text swept from an xterm on an FC2
system into an FC3 window the FC2 xterm dies with this message:
xterm: warning, error event received:
X Error of failed request: BadAtom (invalid Atom parameter)
  Major opcode of failed request: 18 (X_ChangeProperty)
  Atom id of failed request: 0x1de   <-- value changes each time
  Serial number of failed request: 8804 <-- changes each time
  Current serial number of output stream: 868 <-- changes each time

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. open an xterm into an FC2 machine
2. sweep some random text from this xterm
3. try to paste it into the FC3 xterm 
    

Actual Results:  i get the BAdAtom error

Expected Results:  i would expect the text to be pasted into the FC3
window

Additional info:

both machines are fully updated
Comment 1 Tom Morton 2004-11-25 11:05:16 EST
In duplicate bug: 139846

Per Steinar Iversen comments:
"The problem seems to be solved if the new -Y option is passed to ssh
and not -X as in previous versions."

Specifically, if you add the -Y to the ssh to the FC2 machine then the
launched xterm won't exhibit this problem. (worked for me anyway). 
Comment 2 Mike A. Harris 2004-11-25 12:25:00 EST

*** This bug has been marked as a duplicate of 139846 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.