Bug 1396743 - Package musicbrainz-tool as executable
Package musicbrainz-tool as executable
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: abcde (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-19 10:26 EST by Michael J Gruber
Modified: 2017-07-03 05:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-03 05:13:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J Gruber 2016-11-19 10:26:54 EST
Description of problem:
When abcde is configured to use MusicBrainz (rather than CDDB) it calls a tool. But this tool is packaged as non-executable /usr/share/doc/abcde/abcde-musicbrainz-tool.

Version-Release number of selected component (if applicable):
2.7.2-1

How reproducible:
Always

Steps to Reproduce:
1. Call abcde using "-G musicbrainz" or by setting CDDBMETHOD=musicbrainz.


Actual results:
abcde fails to find abcde-musicbrainz-tool

Expected results:
abcde works using this documented setup

Additional info:
The tool also needs a perl module which is not packaged in fedora. This will be filed as a separate bug.
Comment 1 Dominik 'Rathann' Mierzejewski 2016-12-05 08:35:07 EST
If you submit the missing perl package for review, please add the bug number to blocker list here. I don't use that feature, so I don't care too much, but if you get the package added then I'll happily enable musicbrainz-tool in abcde.
Comment 2 Paulo Matos 2017-04-20 10:19:21 EDT
I had some fun with this today on Fedora 25. 
So, according to PR1268596, the script is in doc/ because the perl dependencies are not supported.

I had to install icedax package (available) and using cpan installed WebService-MusicBrainz-0.94 (1.0.1 does not work) and MusicBrainz-DiscID (latest version as of today).

There's no alternative to the musicbrainz CDDB method which means that abcde should either not be supported by Fedora or support should be finished by adding the icedax dep and required perl modules.
Comment 3 Dominik 'Rathann' Mierzejewski 2017-04-21 04:50:56 EDT
(In reply to Paulo Matos from comment #2)
> I had some fun with this today on Fedora 25. 
> So, according to bug 1268596, the script is in doc/ because the perl
> dependencies are not supported.

Not packaged in Fedora, to be precise.

> I had to install icedax package (available)

It's recommended by the abcde package:
$ rpm -q --recommends abcde
flac
icedax
so it gets installed by default if you haven't disabled weak deps installation
in dnf. It's not required, though. Using cdparanoia directly works, too.

> and using cpan installed
> WebService-MusicBrainz-0.94 (1.0.1 does not work) and MusicBrainz-DiscID
> (latest version as of today).
> 
> There's no alternative to the musicbrainz CDDB method which means that abcde
> should either not be supported by Fedora or support should be finished by
> adding the icedax dep and required perl modules.

It worked just fine without musicbrainz last time I converted a CD to FLAC,
so I don't agree here. If you need musicbrainz support then please do what
I asked in comment #1.
Comment 4 Otto J. Makela 2017-04-27 13:30:23 EDT
This same issue with musicbrainz has been around since Fedora 23: see #1268596

What seems to have changed now is that somehow CDDBMETHOD=musicbrainz by default instead of whatever it used to be before that. That value does not work, so abcde does not work out of the box.
Comment 5 Otto J. Makela 2017-04-30 17:05:02 EDT
(In reply to Otto J. Makela from comment #4)

> What seems to have changed now is that somehow CDDBMETHOD=musicbrainz by
> default instead of whatever it used to be before that. That value does not
> work, so abcde does not work out of the box.

A quick fix is to change the configuration file to use CDDBMETHOD=cddb and everything should work as it earlier did. Why was the default changed to be something that won't work on Fedora (and has status CANTFIX, bug 1268596), was this somehow inherited from upstream?
Comment 6 Dominik 'Rathann' Mierzejewski 2017-07-03 05:13:54 EDT
(In reply to Otto J. Makela from comment #5)
[...]
> A quick fix is to change the configuration file to use CDDBMETHOD=cddb and
> everything should work as it earlier did. Why was the default changed to be
> something that won't work on Fedora (and has status CANTFIX, bug 1268596),
> was this somehow inherited from upstream?

Yes, this is the new upstream default which I have changed now. Thanks for the tip. Having said that, I have no plans to package the missing perl modules, so I'm closing this. Feel free to reopen once the requisite packages are added to Fedora.

Note You need to log in before you can comment on or make changes to this bug.