Bug 1396747 - artifacts in poedit
Summary: artifacts in poedit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK3
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-19 15:34 UTC by Baurzhan Muftakhidinov
Modified: 2016-12-04 05:25 UTC (History)
3 users (show)

Fixed In Version: wxGTK3-3.0.2-30.fc25 wxGTK3-3.0.2-30.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-26 22:53:47 UTC
Type: Bug


Attachments (Terms of Use)
Example of poedit window (61.03 KB, image/png)
2016-11-19 15:34 UTC, Baurzhan Muftakhidinov
no flags Details

Description Baurzhan Muftakhidinov 2016-11-19 15:34:14 UTC
Created attachment 1222163 [details]
Example of poedit window

Description of problem:
After update of wxGTK3, the main window of poedit is unusable. 


Version-Release number of selected component (if applicable):
wxGTK3-3.0.2-29.fc25.x86_64
poedit-1.8.11-1.fc25.x86_64
wxBase3-3.0.2-29.fc25.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Update wxGTK3 to wxGTK3-3.0.2-29
2. Launch poedit and open a PO file
3. Fields of PO file are covered by some strange gray widget. 

Actual results:
Screenshot is attached, main window of Poedit is unusable.

Expected results:
Fields should be visible.


Additional info: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b372d67ade

Comment 1 Scott Talbert 2016-11-19 15:38:50 UTC
Yes, I can reproduce the problem.  It looks like the problem does not exist with latest wx git, so there is probably another patch that I need to cherry-pick.  Thanks for the report.

Comment 2 Fedora Update System 2016-11-24 06:31:45 UTC
wxGTK3-3.0.2-30.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cde7d3d168

Comment 3 Fedora Update System 2016-11-24 06:32:17 UTC
wxGTK3-3.0.2-30.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-74bef396a8

Comment 4 Fedora Update System 2016-11-25 09:39:39 UTC
wxGTK3-3.0.2-30.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-74bef396a8

Comment 5 Fedora Update System 2016-11-25 09:42:46 UTC
wxGTK3-3.0.2-30.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cde7d3d168

Comment 6 Fedora Update System 2016-11-26 22:53:47 UTC
wxGTK3-3.0.2-30.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-12-04 05:25:11 UTC
wxGTK3-3.0.2-30.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.