Bug 139677 - OpenOffice.org crashes when trying to save table changes to MySQL using unixODBC/myODBC connector...
OpenOffice.org crashes when trying to save table changes to MySQL using unixO...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 09:06 EST by Nate Moseman
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: FC4/2.0.1.1-5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 08:16:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Moseman 2004-11-17 09:06:48 EST
I was following the directions in the PDF titled: "OpenOffice 1.0,
ODBC, and MySQL 'How-to'" aviable from
www.unixodbc.org/doc/OOoMySQL9.pdf and got to page 9.

I created the sample table from the PDF in the Table Design
wizard/dialog/whatever, and when I went to save it, openoffice.org
crashed and the Bug Buddy popped up.

Did it twice in a row, I closed out, logged out, logged back in, and
did it again and it crashed once more.

Steps to reproduce the crash:
1. setup MySQL server to accept connections from OO.org and the ODBC
connector. 
2. setup OO.org using the Data Source Administrator to use the ODBC to
access a test database in mysql
3. goto view --> datasources, select the mysql database, expand it,
right click on tables, select new table design.
4. create table with a few entries,
5. save table,
6. crash

Expected Results:

I expect it to save the table so that I can continue on with the howto.

Additional Information:

I tried a few more times trying different things and it did exactly
the same thing over and over again. I could issue a SQL command from
OO.org and create a table manually, and I could open and edit it. But
when I would go to save it, it crashed.

I could make queries and save queries just fine though.

However I believe that I fixed it, at least sort of.

I went to MySQL's website and downloaded the current production MyODBC
connector RPM and installed that over the MyODBC package I installed
thru Apt-get from one of the Official Fedora Mirrors (no third party
repositories setup)

Now I can edit, create, delete, and save tables just fine. 

The one catch is that I now have no edit option from "Data Sources"
Window. In order to get to edit mode I have to go thru the
"Administrate Data Sources" window and select the tables tab and from
their I can right click and edit the tables and save them successfully.

So I am not sure if I should of posted this under "myODBC" or not. It
needs to be upgraded, I guess. Still doesn't quite seem right, I
should be able to edit it from Data Sources Window per instructions
from the howto PDF. Maybe OO.org needs to be upgraded to 1.1.3? 

I am content with the workaround so far...
Comment 1 Nate Moseman 2004-11-17 15:30:54 EST
Dammit. 

I went back to edit the table. It won't let me edit or change any
actual columns, but it'll let me add them. I can add them and save it
and it'll work.

But I can't do something like deleting them. If I do that I get a SQL
error.

Sucks. 

So I am now using all the newest versions of unixODBC, myODBC and now
OpenOffice.org (1.1.3) and it's still giving me a SQL error.

Maybe I just don't get it. Maybe the SQL stuff is fubared. I don't
know. I give up. Maybe I'll hit up the OO.org website and see if I can
get help from them.
So I suppose it's nothing you can do anything about. :(
Oh, well.
Comment 2 Caolan McNamara 2005-01-27 08:50:49 EST
what was your locale ? There was a bug in the odbc drivers where locales with
comma seperators instead of  . for the decimal mark caused problems.
Comment 3 Caolan McNamara 2005-01-28 05:41:54 EST
caolanm->tgl: Could you take a look at this, I haven't been able to reproduce
anything like it, except the old setlocale issue.
Comment 4 Nate Moseman 2005-01-28 13:15:48 EST
I am sorry. I am the guy that filed the bug report and it's been a while since I
stopped messing around with it. Hell, I don't even own the computer I was trying
that on.

All I figured is that this stuff is semi-hidden in OO.org for a reason. I
understand that they are pretty much redoing this stuff for the next release.

If you want me to I can try to setup a similar situation on this computer, but I
don't know how usefull that will be for you.
Comment 5 Tom Lane 2005-01-28 18:51:34 EST
Hmm, seems this is still there in FC3 tip.  I got a crash with
openoffice.org-1.1.2-11.5.fc3
unixODBC-2.2.9-1
MyODBC-2.50.39-20
mysql-server-3.23.58-14

It's not the locale problem because I was using good 'ol C locale.  I'm not
convinced it's very closely associated with the odbc code at all, in fact,
because the crash doesn't seem to be near there.  ooffice printed out this:

sh: bug-buddy: command not found


Fatal exception: Signal 11
Stack:
/usr/lib/ooo-1.1/program/libsal.so.3[0x8efb73]
/usr/lib/ooo-1.1/program/libsal.so.3[0x8efd00]
/usr/lib/ooo-1.1/program/libsal.so.3[0x8efdc9]
/lib/tls/libpthread.so.0[0x5b68d8]
/usr/lib/ooo-1.1/program/libsal.so.3(rtl_convertTextToUnicode+0x7e)[0x90ec47]
/usr/lib/ooo-1.1/program/libsal.so.3(rtl_string2UString+0x116)[0x8fdc83]
/usr/lib/ooo-1.1/program/libodbcbase2.so(_ZN12connectivity4odbc11OConnection10ge
tCatalogEv+0x149)[0x66623a7]
/usr/lib/ooo-1.1/program/libdbu645li.so[0x5f7d26e]
/usr/lib/ooo-1.1/program/libdbu645li.so[0x5ef1a64]
/usr/lib/ooo-1.1/program/libdbu645li.so[0x5ef1552]
/usr/lib/ooo-1.1/program/libdbu645li.so[0x604ce93]
/usr/lib/ooo-1.1/program/libdbu645li.so[0x604cf41]
/usr/lib/ooo-1.1/program/libdbu645li.so[0x604cf1a]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN7ToolBox6SelectEv+0x4e)[0x35c07d8]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN7ToolBox23ImplHandleMouseButtonUpERK1
0MouseEventh+0x174)[0x35bb46e]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN7ToolBox8TrackingERK13TrackingEvent+0
x45)[0x35bc25f]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN6Window11EndTrackingEt+0x12e)[0x35dc1
28]
/usr/lib/ooo-1.1/program/libvcl645li.so(_Z20ImplHandleMouseEventP6Windowthllmtt+
0x10d6)[0x35defc8]
/usr/lib/ooo-1.1/program/libvcl645li.so(_Z19ImplWindowFrameProcPvP8SalFrametPKv+
0xc3)[0x35e1b1b]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so(_ZN11X11SalFrame16HandleMouseEve
ntEP7_XEvent+0x54c)[0xeb83ba]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so(_ZN11X11SalFrame8DispatchEP7_XEv
ent+0x121)[0xeba1cd]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so(_ZN13SalX11Display8DispatchEP7_X
Event+0x263)[0xee5595]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so(_ZN13SalX11Display5YieldEh+0x9b)
[0xee5317]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so[0xee1068]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so(_ZN7SalXLib5YieldEh+0x3cb)[0xedf
d13]
/usr/lib/ooo-1.1/program/libvclplug_gen645li.so(_ZN14X11SalInstance5YieldEh+0x31
)[0xee89a1]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN11Application5YieldEv+0x64)[0x348dd72
]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN11Application7ExecuteEv+0x35)[0x348dc
7f]
/usr/lib/ooo-1.1/program/soffice.bin(_ZN7desktop7Desktop4MainEv+0x1f1c)[0x806536
c]
/usr/lib/ooo-1.1/program/libvcl645li.so(_Z6SVMainv+0x4a)[0x3492af8]
/usr/lib/ooo-1.1/program/libvcl645li.so(main+0x4c)[0x3645690]
/lib/tls/libc.so.6(__libc_start_main+0xe3)[0x37de33]
/usr/lib/ooo-1.1/program/soffice.bin(_ZN6Window11RequestHelpERK9HelpEvent+0x31)[
0x805e0d5]
Aborted

Let me know what I can/should do to gather more info for you.
Comment 6 Dan Williams 2005-02-21 10:52:38 EST
Cute, rtl_convertTextToUnicode().  Any way to convince you to install all 500MB
of openoffice.org-debuginfo?
Comment 7 Tom Lane 2005-02-21 15:38:39 EST
[ checks disk space... ]  Yeah, I can do that.  Just install it and repeat the
test and I should get a better backtrace, right?
Comment 8 Dan Williams 2005-02-21 15:48:08 EST
Yeah, it should show the file, line #, and arguments passed to each function on
each line of the stacktrace.
Comment 9 Tom Lane 2005-02-21 18:26:36 EST
Well, since that report I've yum updated and now have
openoffice.org-1.1.3-6.5.0.fc3
but the other packages are the same as before.  I pulled the matching debuginfo
down, but no joy.  What I find is that it still crashes immediately on hitting
"Save" in the Table Design dialog, but now the printout is just
sh: bug-buddy: command not found
no backtrace :-(.  Setting "ulimit -c unlimited" didn't persuade it to drop a
core file either.  Now what?
Comment 10 Jef Spaleta 2005-06-07 21:55:23 EDT
Hmm not sure if its related but i seem to be able to reproduce the crash on save
even without the odbc stuff installed. Start a new text document.. add a little
text...go to save get a bug buddy crash. However when using saveas instead
things work.

openoffice.org-1.1.3-11.5.0.fc3

Should i open this as a new bug?

-jef

Comment 11 Caolan McNamara 2006-04-12 08:16:36 EDT
cvs diff -r1.30 -r1.31 connectivity/source/drivers/odbc/OConnection.cxx

"#117841 # the size given to external components is now reduced by 1 to avoid
that they corrupt our return address"

Note You need to log in before you can comment on or make changes to this bug.