Bug 1396818 - QGIS packages needs qca-ossl dependency
Summary: QGIS packages needs qca-ossl dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qgis
Version: 24
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Volker Fröhlich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-20 14:48 UTC by markusN
Modified: 2017-07-31 00:20 UTC (History)
4 users (show)

Fixed In Version: qgis-2.16.3-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-30 17:47:43 UTC


Attachments (Terms of Use)

Description markusN 2016-11-20 14:48:09 UTC
Any 2.1x version of QGIS shows on Fedora at startup the following message:

"Authentication System: DISABLED. Resources authenticating via the system can not be accessed"

I had reported this to QGIS at
https://hub.qgis.org/issues/14651

Indeed, it is a missing package to be installed (simply a SPEC file tweak is needed here) - the warning message indicates that the installation misses "qca-ossl" (OpenSSL plugin for QCA). Solution:

dnf install qgis qgis-grass qgis-python qca-ossl [...]

Essentially, "qca-ossl" is a requirement when installing QGIS and the SPEC file should be modified accordingly. Thanks.

Comment 1 markusN 2016-12-28 09:27:42 UTC
Thanks for having added this to QGIS 2.18.0-2 RPM and later. Closing.

Comment 2 Fedora Update System 2016-12-30 11:09:53 UTC
qgis-2.14.3-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ce2d38e484

Comment 3 Fedora Update System 2016-12-30 11:10:58 UTC
qgis-2.16.3-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-90107dc0c4

Comment 4 Fedora Update System 2016-12-31 09:27:33 UTC
qgis-2.16.3-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-90107dc0c4

Comment 5 Fedora Update System 2016-12-31 09:51:31 UTC
qgis-2.14.3-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ce2d38e484

Comment 6 Fedora End Of Life 2017-07-25 23:57:19 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 7 Volker Fröhlich 2017-07-30 17:47:43 UTC
Sorry, I somehow forget to push the update. It's solved in F25 now.

Comment 8 Fedora Update System 2017-07-31 00:20:34 UTC
qgis-2.16.3-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.