Bug 1396844 - dnf should provide more debug info when resolving deps
Summary: dnf should provide more debug info when resolving deps
Keywords:
Status: CLOSED DUPLICATE of bug 1303978
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-20 21:39 UTC by Fabrice Bellet
Modified: 2016-11-21 09:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-21 09:03:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Fabrice Bellet 2016-11-20 21:39:26 UTC
dnf should provide more debugging information about the way it resolves packages dependencies, and more important, about which package adds which "require" to the transaction set.

The --debugsolver option generates a lot of data about the content of enabled repo, but I could not find the debug output of _how_ dnf uses all this information.

Comment 1 Igor Gnatenko 2016-11-21 09:03:36 UTC

*** This bug has been marked as a duplicate of bug 1303978 ***


Note You need to log in before you can comment on or make changes to this bug.