Bug 1396851 - [RFE] [OpenStack] assign a floating IP address to each instance so it can be reached over SSH
Summary: [RFE] [OpenStack] assign a floating IP address to each instance so it can be ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general   
(Show other bugs)
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.0
Assignee: matt jia
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: FutureFeature, Patch, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-20 23:51 UTC by Dan Callaghan
Modified: 2017-02-21 18:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-21 18:49:07 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2016-11-20 23:51:45 UTC
As per subject. Currently instances only have their internal IP address which means they cannot be contacted directly. Specifically, users expect to be able to SSH to the machine where their recipe is running.

Comment 1 matt jia 2016-11-28 01:16:06 UTC
We tried this when using the nova network env and it turns out that there is an issue

https://bugzilla.redhat.com/show_bug.cgi?id=1100181#c5

I think this issue still exists in the neutron network env and cannot be fixed either.

Comment 2 Dan Callaghan 2016-11-28 01:25:25 UTC
Hmm I think I wrote that back when we were still using Nova networking... the situation is a bit different now in the newer environment with Neutron, so I think we can revisit it.

Comment 3 Dan Callaghan 2016-11-28 01:25:49 UTC
But thank you for reminding me of why we took it out, I knew there was a reason but couldn't remember it last week :-)

Comment 4 matt jia 2016-12-08 01:36:48 UTC
On Gerrit:

   https://gerrit.beaker-project.org/#/c/5517/

I have tried this in my testing env and did not hit the issue mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1100181#c5, so I think the issue has been resolved in the new env.

Comment 7 Dan Callaghan 2017-02-21 18:49:07 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.