Bug 1396992 - dnf repoquery/whatrequires doesn't work correctly
dnf repoquery/whatrequires doesn't work correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
25
All Linux
high Severity urgent
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-21 05:56 EST by Artem S. Tashkinov
Modified: 2017-04-01 13:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-01 13:21:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem S. Tashkinov 2016-11-21 05:56:06 EST
Description of problem:

dnf -C repoquery --alldeps --whatrequires atk-2.20.0-1.fc24.i686
Last metadata expiration check: 0:35:54 ago on Mon Nov 21 10:16:31 2016.
<empty output>

Version-Release number of selected component (if applicable):

dnf-plugins-core-0.1.21-3.fc24.noarch

Expected results:

dnf remove atk-2.20.0-1.fc24.i686

==============================================================================================================================================================================================
 Package                                            Arch                                  Version                                          Repository                                    Size
==============================================================================================================================================================================================
Removing:
 atk                                                i686                                  2.20.0-1.fc24                                    @@commandline                                1.2 M
 avahi-libs                                         i686                                  0.6.32-4.fc24                                    @updates                                     144 k
 cups-libs                                          i686                                  1:2.1.4-2.fc24                                   @updates                                     807 k
 gdk-pixbuf2                                        i686                                  2.34.0-1.fc24                                    @@commandline                                2.4 M
 gdk-pixbuf2-modules                                i686                                  2.34.0-1.fc24                                    @@commandline                                211 k
 gdk-pixbuf2-xlib                                   i686                                  2.34.0-1.fc24                                    @@commandline                                 67 k
 gtk2                                               i686                                  2.24.31-1.fc24                                   @updates                                      13 M
 jasper-libs                                        i686                                  1.900.13-1.fc24                                  @updates                                     321 k
 mesa-libGLU                                        i686                                  9.0.0-10.fc24                                    @@commandline                                462 k
 pangox-compat                                      i686                                  0.0.2-7.fc24                                     @@commandline                                160 k
 pangox-compat                                      x86_64                                0.0.2-7.fc24                                     @@commandline                                165 k

Transaction Summary
==============================================================================================================================================================================================
Remove  11 Packages
Comment 1 Igor Gnatenko 2016-11-21 06:00:55 EST
I guess it's because of arch.
Comment 2 Honza Silhan 2016-11-21 07:29:29 EST
Thanks for the report. We will investigate whether it works in the upstream for the provide name only. For specifying package I would consider it as RFE (note: the semantic woudl be different from rpm -qi and repoquery of yum.
Comment 3 Jaroslav Mracek 2017-02-17 05:42:19 EST
I create PR that should fix the problem https://github.com/rpm-software-management/dnf/pull/740

Hope that it helps
Comment 4 Fedora Update System 2017-03-21 08:07:06 EDT
dnf-2.1.1-1.fc26 libdnf-0.8.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-65586fa42b
Comment 5 Fedora Update System 2017-03-21 10:26:54 EDT
dnf-2.1.1-1.1.fc26, libdnf-0.8.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-65586fa42b
Comment 6 Fedora Update System 2017-03-27 15:20:26 EDT
dnf-2.2.0-1.fc26, libdnf-0.8.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-65586fa42b
Comment 7 Fedora Update System 2017-04-01 13:21:10 EDT
dnf-2.2.0-1.fc26, libdnf-0.8.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.