Bug 1397006 - No PDF and TIFF export in djview4
Summary: No PDF and TIFF export in djview4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: djview4
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-21 11:39 UTC by Artem
Modified: 2016-12-07 07:54 UTC (History)
1 user (show)

Fixed In Version: djview4-4.10.6-4.fc25 djview4-4.10.6-4.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-07 05:24:13 UTC


Attachments (Terms of Use)
Djvu file to test. (143.75 KB, image/vnd.djvu)
2016-11-21 11:39 UTC, Artem
no flags Details

Description Artem 2016-11-21 11:39:22 UTC
Created attachment 1222363 [details]
Djvu file to test.

Description of problem:
Program doesn't let to export ".djvu" file as ".pdf" file or ".tiff" images since there is no such menu items in drop-down menu.

Version-Release number of selected component (if applicable):
Name        : djview4
Arch        : x86_64
Epoch       : 0
Version     : 4.10.6
Release     : 3.fc24
Size        : 1.8 M
Repo        : @System
From repo   : updates
Summary     : DjVu viewer
URL         : http://djvu.sourceforge.net/djview4.html
License     : GPLv2+

How reproducible:
No menu items in drop-down menu. They should be placed there because pdf or tiff conversion is one of the most important features of this piece of software.

Steps to Reproduce:
1. Start djview4
2. Open any ".djvu" file or attached "example.djvu".
3. Go to "File > Export as..."
4. In the "Export" tab in "Destination" section choose "Format:" by opening drop-down menu.
5. There should be "PDF Document" and "TIFF image" items in addition to existing ones but they dont exist.

Actual results:
No results!

Expected results:
Pdf conversion from ".djvu" files.

Additional info:
This bug affects only djview4 from Fedora repository. This program exports files as it supposed to on any other distros like ubuntu or debian.

Comment 1 Igor Gnatenko 2016-11-22 00:01:17 UTC
I guess PDF support completely depends on TIFF. Adding BRs should enable it.

Comment 2 Terje Røsten 2016-11-24 17:40:07 UTC
Thanks for report, verified.

Comment 3 Fedora Update System 2016-11-27 12:56:23 UTC
djview4-4.10.6-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-97bbdf4679

Comment 4 Fedora Update System 2016-11-27 12:56:31 UTC
djview4-4.10.6-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1e7a4853b

Comment 5 Fedora Update System 2016-11-28 09:33:41 UTC
djview4-4.10.6-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1e7a4853b

Comment 6 Fedora Update System 2016-11-28 09:36:50 UTC
djview4-4.10.6-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-97bbdf4679

Comment 7 Fedora Update System 2016-12-07 05:24:13 UTC
djview4-4.10.6-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-12-07 07:54:47 UTC
djview4-4.10.6-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.