Bug 139702 - kio_smb failed to load
Summary: kio_smb failed to load
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Simo Sorce
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 16:49 UTC by Vladimir Kondratiev
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 3.0.24-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 14:40:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vladimir Kondratiev 2004-11-17 16:49:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Unable to open smb:// URL in konqueror running in KDE session.

Version-Release number of selected component (if applicable):
kdebase-3.3.1-7
samba-3.0.8-3

How reproducible:
Always

Steps to Reproduce:
1.Start KDE session
2.Open konqueror
3.go to URL "smb:/"
    

Actual Results:  An error occurred while loading smb:/:


Could not start process Unable to create io-slave:
klauncher said: Error loading 'kio_smb'.
.

Expected Results:  Available SMB domains displayed

Additional info:


If konqueror run from XFCE or Gnome session, or from KDE session
running under different user, it do open smb:// URL's as expected.

Comment 1 Ngo Than 2004-11-17 19:05:19 UTC
it looks like samba-3.0.8-3 is broken in rawhide. it works fine with
samba version in FC3.

hier is a testcase.

char smbc_new_context ();
int main ()
{
  smbc_new_context ();
  return 0;
}


gcc -o test test.c -lsmbclient
/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../../lib64/libsmbclient.so:
undefined reference to `secrets_fetch_machine_password'
/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../../lib64/libsmbclient.so:
undefined reference to `secrets_fetch'
/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../../lib64/libsmbclient.so:
undefined reference to `secrets_delete'
/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../../lib64/libsmbclient.so:
undefined reference to `secrets_store

Comment 2 Vladimir Kondratiev 2004-11-21 20:28:53 UTC
I get samba-3.0.9-1.src.rpm from www.samba.org and build it. Konqueror
work fine with kio_smb now.
Can it be considered as fix?

Comment 3 Guenther Deschner 2007-03-15 14:40:49 UTC
The libsmbclient linkage is definitely fixed in 3.0.24.

Please reopen if it is still an issue.


Note You need to log in before you can comment on or make changes to this bug.