Bug 139710 - airo_cs: infinite loop on shutdown
airo_cs: infinite loop on shutdown
Status: CLOSED DUPLICATE of bug 139709
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 12:41 EST by Kjartan Maraas
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2004-11-17 12:41:26 EST
Description of problem:
If I shut down my laptop without stopping the pcmcia service the
machine enters an infinite loop where the airo driver spews the
console with a lot of diagnostics and messages saying it's waiting for
the device to become free and that the use count is still 1. I also
see the following when doing service pcmcia start/stop:

[root@localhost wireless]# service pcmcia stop
Shutting down PCMCIA services: ERROR: Module pcmcia_core is in use by
yenta_socket
done.
[root@localhost wireless]# service pcmcia start
Starting PCMCIA services: cardmgr[3746]: open_sock(socket 2) failed:
Bad file descriptor
cardmgr[3746]: watching 2 sockets
done.
[root@localhost wireless]#

[root@localhost wireless]# lsmod |grep airo
airo_cs                 7237  0
airo                   64225  1 airo_cs
ds                     16965  5 airo_cs
pcmcia_core            59913  3 airo_cs,ds,yenta_socket

00:0b.0 CardBus bridge: O2 Micro, Inc. OZ711M1 SmartCardBus
MultiMediaBay Controller (rev 20)

The card is a Cisco Aironet 350
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-11-18 03:42:15 EST

*** This bug has been marked as a duplicate of 139709 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.