Bug 1397129 - file open dialog doesn't redraw correctly on radeon driver with 4.0.4, works well with 4.0.0
Summary: file open dialog doesn't redraw correctly on radeon driver with 4.0.4, works ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-21 17:00 UTC by Kamil Páral
Modified: 2017-01-10 15:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 15:27:08 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
bug demonstration video (881.56 KB, application/octet-stream)
2016-11-21 17:03 UTC, Kamil Páral
no flags Details
rpm -qa (99.49 KB, text/plain)
2016-11-21 17:03 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2016-11-21 17:00:50 UTC
Description of problem:
I'm not able to select a custom ISO in file open dialog in mediawriter 4.0.4 on Fedora 24, because the dialog does not redraw correctly. I usually see just a gray area, and sometimes I see folders, but I can't open any of them, because again I see only gray area. See attached video.

If I install qgnomeplatform (and adwaita-qt5 as a dep), the file open dialog doesn't open at all and I have to kill the app (it's frozen)

In both cases, when I (try to) open the dialog, journal prints:
Nov 21 17:57:49 titan org.gnome.Shell.desktop[1332]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2600007 ()

In case it's relevant, I have configured tracker to not crawl any of my directories.


Version-Release number of selected component (if applicable):
mediawriter-4.0.4-0.fc24.x86_64


How reproducible:
always

Steps to Reproduce:
1. try to select a custom iso
2. see the file open dialog gray / not working

Comment 1 Kamil Páral 2016-11-21 17:03:20 UTC
Created attachment 1222441 [details]
bug demonstration video

Comment 2 Kamil Páral 2016-11-21 17:03:39 UTC
Created attachment 1222443 [details]
rpm -qa

Comment 3 Kamil Páral 2016-11-21 17:04:12 UTC
To clarify, I'm using X11 on F24.

Comment 4 Kamil Páral 2016-11-21 17:09:13 UTC
$ lspci -k | grep VGA -A3
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 3050
	Kernel driver in use: radeon
	Kernel modules: radeon

Comment 5 Kamil Páral 2016-11-21 17:24:30 UTC
I can't reproduce this when I run with nomodeset (therefore forcing a fallback driver). I also don't see this in a VM. That suggests this is radeon-driver specific.

As a workaround, running this:

$ QSG_RENDER_LOOP=threaded mediawriter

causes the dialog to render fine.

Comment 6 Kamil Páral 2016-11-21 20:20:14 UTC
Update:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-173cdae8b0

Comment 7 Kamil Páral 2016-11-22 09:28:29 UTC
I have tested this on my R9 270, and also on AMD APU with integrated R7 Kaveri graphics. Both fail with 4.0.4 and work with 4.0.5.

Comment 8 Kamil Páral 2016-11-22 11:05:44 UTC
Since this is now fixed and only affected F25 for a short while, I'm removing CommonBugs.


Note You need to log in before you can comment on or make changes to this bug.