Bug 139715 - Invalid ntp.conf created by dhclient-script
Invalid ntp.conf created by dhclient-script
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 170783 170784
  Show dependency treegraph
 
Reported: 2004-11-17 13:20 EST by Davide Bolcioni
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.0.1-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 04:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2004-11-17 13:20:52 EST
Description of problem:
If DHCP provides the NTP server, dhclient-script generates ntp.conf
but uses "authenticate yes" which ntp-4.2.0.a.20040617-4 dislikes as
/var/log/messages shows:
Nov 17 19:11:37 host ntpd[4047]: configure: keyword "authenticate"
unknown, line ignored

Version-Release number of selected component (if applicable):
dhclient-3.0.1-11

How reproducible:
Always.

Steps to Reproduce:
1. Configure DHCP server to send NTP server option.
2. Boot client
3. Observe generated ntp.conf and the complaint in /var/log/messages.
  
Actual results:
As above.

Expected results:
A valid configuration.

Additional info:
By the way, rpm -qf shows /sbin/dhclient-script as belonging to
dhclient, but there is no dhclient component for Fedora Core 3 in this
Bugzilla ?
Comment 1 Davide Bolcioni 2004-11-17 13:30:40 EST
Please note that I do not believe this is a duplicate of the various
earlier problems with ntp.conf documented in Bugzilla; I bothered with
a quick check. It seems that "authenticate yes" is no longer liked by
ntp, although it used to be fine.
Comment 2 Jason Vas Dias 2004-11-17 16:17:38 EST
 The dhclient-script was overwriting the /etc/ntp.conf and
 /etc/ntp/step-tickers files when it received new ntp servers
 from the DHCP server.
 With dhcp-3.0.1-14, DHCP now merges in only the new servers
 with the existing ntp.conf contents, so other non-server 
 configuration is preserved.
 dhcp-3.0.1-14 will be available from tomorrow in the Fedora 
 Development (rawhide) repository, and from :
   http://people.redhat.com/~jvdias/DHCP/FC3/
 Please test dhcp-3.0.1-14 and let me know how it works - then
 if it works ok I'll push it to FC3 updates.
 

Note You need to log in before you can comment on or make changes to this bug.